7

I'm trying to run a certain program and I get the errors

/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by ./software1_runtime)
/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /opt/software1/bin/../lib/libsoftware.so.4)

I did the command

sudo find / -name "libstdc++.so.6*"

and got the results

/home/user/SOFTWARE2/run/bin/linux64/libstdc++.so.6
/home/user/SOFTWARE2/partners/ist/lmt-6.7/extern/bin/linux_n64_g41/libstdc++.so.6.0.8
/home/user/SOFTWARE2/partners/ist/lmt-6.7/extern/bin/linux_n64_g41/libstdc++.so.6
/home/user/SOFTWARE2/run/bin/linux64/libstdc++.so.6
find: ‘/run/user/1000/gvfs’: Permission denied
/usr/lib/libstdc++.so.6
/usr/lib/libstdc++.so.6.0.19
/usr/lib64/libstdc++.so.6
/usr/lib64/libstdc++.so.6.0.19
/usr/share/gdb/auto-load/usr/lib64/libstdc++.so.6.0.19-gdb.py
/usr/share/gdb/auto-load/usr/lib64/libstdc++.so.6.0.19-gdb.pyc
/usr/share/gdb/auto-load/usr/lib64/libstdc++.so.6.0.19-gdb.pyo
/usr/share/gdb/auto-load/usr/lib/libstdc++.so.6.0.19-gdb.py
/usr/share/gdb/auto-load/usr/lib/libstdc++.so.6.0.19-gdb.pyc
/usr/share/gdb/auto-load/usr/lib/libstdc++.so.6.0.19-gdb.pyo

What do I need to do to fix this?

I ran the following command

strings /usr/lib64/libstdc++.so.6 | grep CXXABI

and got the following results

CXXABI_1.3
CXXABI_1.3.1
CXXABI_1.3.2
CXXABI_1.3.3
CXXABI_1.3.4
CXXABI_1.3.5
CXXABI_1.3.6
CXXABI_1.3.7
CXXABI_TM_1

So it looks like I need to download 1.3.8 and 1.3.9 but where

2 Answers 2

6

I am no developer and this answer is not great, but I hope it helps.

In trying to get Igel UMS Management interface to run on CentOS 7, I ran into the same error. For me the answer was to compile and install a newer version of GCC using the following steps.

yum install gmp-devel mpfr-devel libmpc-devel wget
wget https://ftp.gnu.org/gnu/gcc/gcc-8.3.0/gcc-8.3.0.tar.gz
mkdir gcc-8.3.0-build
tar xf gcc-8.3.0.tar.gz
cd gcc-8.3.0-build
../gcc-8.3.0/configure --enable-languages=c,c++ --disable-multilib
make && make install
export LD_LIBRARY_PATH=/usr/local/lib64:${LD_LIBRARY_PATH}

https://gcc.gnu.org/wiki/InstallingGCC

https://jdhao.github.io/2017/09/04/install-gcc-newer-version-on-centos/

1
  • After the new version was compiled and installed, I did this: sudo unlink /usr/lib64/libstdc++.so.6 and sudo cp /usr/local/lib64/libstdc++.so.6 /usr/lib64 because for me this new version wasn't visible.
    – Andron
    Commented Sep 29, 2022 at 17:22
0

"CXXABI_1.3.9 is associated with gcc version 5.1. CentOS 7 has gcc 4.8.5.", as mentioned here: https://forums.centos.org/viewtopic.php?t=68062

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .