0

I have a Dell Latitude 3590 with Windows 10 installed as factory setting. I previously installed ubuntu 18.04.2-desktop with an iso image on a usb drive with dual boot allowing me to choose between ubuntu and windows 10. For various reasons, I wanted to reinstall ubuntu 18.02.4 as brand new. In doing so, I chose "delete ubuntu and reinstall" (or something like that during reinstallation) and something failed at the very end of the installation. Ubuntu opened, but since I restarted, I can't access it again. When I turn the PC on, it tries to boot on ubuntu, but ends up with "GNU Grub 2.0" as a command line. When I get in the Bios, I can either boot ubuntu (which gets me back to grub) or windows, or a usb drive in legacy mode. I cannot boot a live ubuntu version either, because I don't get that option : trying to boot from a usb drive with ubuntu on it gets me directly to grub without asking what kind of installation I want for ubuntu.

I would like to be back to my intial state, which was dual boot between ubuntu and windows.

My main hard drive is partitioned as follows :
-a 650 Mo partition labelled "Healthy : Partition of EFI system" -OS (C:) which is the main partition with windows 10 on it (442 Go NFTS)
- another partition with 450 Go on it labelled as "main partition", which is supposed to have ubuntu on it since it's the space I allowed for ubuntu in the first place
-the WINRETOOLS partition (990 Mo NFTS), labelled "healthy - OES partition" (I don't know what it means).

I have tried :
-putting super_grub2_disk ISO image on a usb drive in order to restore grub. After some more or less random errands, i learned that the partitions sizes appear to "not match". I tried use it to install /dev/sda5 (where the ubuntu partition appears to be), but got errors. When i exited it, it made ubuntu boot, but that doesn't solve the booting problem, I would like to have a proper dual boot and not have to dot that every time I want to boot ubuntu.
-putting boot_repair_disk ISO image on USB drive to try to repair it. However, I can only boot from a USB drive in legacy mode, and this appears to prevent any action. It tells me that I need too boot the USB drive in EFI mode, which I apparently cannot.
- delete or format the 3rd partition which is supposed to have ubuntu on it (I've been led to understand that I can't reinstall ubuntu due to the information related to the partitions) in order to reinstall it from scratch. I wasn't allowed to do it by windows, nor from partition manager, nor from diskpart, nor through the registry with regedit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.