0

On a SLES12 with 4 physical NIC, having them in a bond0.

eth0 shows "Link detected: no".

But if I remove eth0 from the bond0 and do an "ifup eth0", it will show "Link detected: yes" and everything looks fine on eth0:

BEFORE:

SERVER:/etc/sysconfig/network # ethtool eth0
Settings for eth0:
        Supported ports: [ FIBRE ]
        Supported link modes:   10000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: No
        Advertised link modes:  10000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: No
        Speed: Unknown!
        Duplex: Unknown! (255)
        Port: Direct Attach Copper
        PHYAD: 0
        Transceiver: external
        Auto-negotiation: off
        Supports Wake-on: umbg
        Wake-on: g
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: no
SERVER:/etc/sysconfig/network # 

removing eth0 from bond0:

SERVER:/var/log # ifenslave -d bond0 eth0
SERVER:/var/log # ifup eth0 # this re-adds the eth0 to the bond0

AFTER:

SERVER:/etc/sysconfig/network # ethtool eth0
Settings for eth0:
        Supported ports: [ FIBRE ]
        Supported link modes:   10000baseT/Full
        Supported pause frame use: No
        Supports auto-negotiation: No
        Advertised link modes:  10000baseT/Full
        Advertised pause frame use: No
        Advertised auto-negotiation: No
        Speed: 10000Mb/s
        Duplex: Full
        Port: Direct Attach Copper
        PHYAD: 0
        Transceiver: external
        Auto-negotiation: off
        Supports Wake-on: umbg
        Wake-on: g
        Current message level: 0x00000007 (7)
                               drv probe link
        Link detected: yes
SERVER:/etc/sysconfig/network #

The big question: What could cause such a behaviour?

It looks like it is not a physical issue, rather some config or bug?

UPDATE: checked on switch side, config looks OK!

  • 1
    a bond(ing) also has to be configured on the Switching side, was it done? – Rui F Ribeiro Feb 27 at 11:52
  • we checked, thanks, but nothing bad was found. Also updated the question, many thanks :) – cirka547 Feb 27 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.