0

I am moving a Wordpress site to a new dedicated host.

I have managed to move the assets and import the wordpress database.

I update the wp_options to the tempory domain name (until I'm ready to make the switch)

But if I add the .htaccess file in I get the following error page when I try to access 'http://xxxxx.com/wp-admin/'

This is the page I see...

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at root@localhost to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

The .htaccess file looks like this...

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

I suspect this is in part due to something I'm missing in the Apache Webserver Directive for port 80.

This is what I have set...

DocumentRoot "/usr/share/wordpress"   
<Directory "/usr/share/wordpress">
 Allow From All                                           
 Options None                                             
 Require all granted                                      
</Directory>

This is my apache setup..

apache

I do not have any directives setup for port 443 at the moment, just this..

DocumentRoot /usr/share/wordpress 
ErrorLog /var/log/httpd/error.log      
CustomLog /var/log/httpd/access.log combined 
UseCanonicalName off 

I have removed out the certificate values until I move the server.

What am I missing?

0

In your apache config, try adding "AllowOverride All", save, restart apache and try again.

Ex:

DocumentRoot "/usr/share/wordpress"   
<Directory "/usr/share/wordpress">
 Allow From All
 AllowOverride All                                           
 Options None                                             
 Require all granted                                      
</Directory>

For more info, see: https://httpd.apache.org/docs/2.4/mod/core.html#AllowOverride

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.