0

I am trying to get a samba share setup so that users have both read and write permissions. I thought that I would be able to do this by editing /etc/samba/smb.conf to add my share like so:

[CLOUD]
   path = /cloud
   writable = yes
   security = user
   valid users = neon, win
   write list = neon, win

and then running:

$ sudo systemctl restart smb.service
$ sudo systemctl restart nmb.service

I can access my share from the two accounts, but neither can write. When I run testparam, some of the parameters are missing(security and writable, but there is no explicit error.

rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[homes]"
Processing section "[printers]"
Processing section "[CLOUD]"
Global parameter security found in service section!
Loaded services file OK.
Server role: ROLE_STANDALONE


Press enter to see a dump of your service definitions

# Global parameters
[global]
    dns proxy = No
    log file = /usr/local/samba/var/log.%m
    max log size = 50
    server role = standalone server
    server string = Samba Server
    workgroup = MYGROUP
    idmap config * : backend = tdb


[homes]
    browseable = No
    comment = Home Directories
    read only = No


[printers]
    browseable = No
    comment = All Printers
    path = /usr/spool/samba
    printable = Yes


[CLOUD]
    path = /cloud
    read only = No
    valid users = neon win
    write list = neon win

I take this to mean that the writable = yes parameter is not being recognized, but since there are no errors I have no idea why. Any suggestions as to what might be going on here? I am using Arch.

1

Try this:

[CLOUD]
    writeable = yes
    path = /cloud
    valid users = neon,win

Restart smbd

Check also read/write permissions directly in your Linux system when you have logged in as user neon or win.

I often had to sign out/in again in Windows

  • You were right, it was a permission issue. I had ran chmod 777 on my shared folder and it seems ok now. I'm still a bit confused about the output of testparm but I guess that doesn't matter since it wasn't even the problem. Unfortunately that did not work. Also, the output of testparm is still different than the smb.conf file in that it says read only = No and writeable = yes is missing. – Stonecraft Feb 26 at 12:00
  • Well, I still cant write from the neon (linux) user. But I guess that is a separate problem because Windows can write to the share now. – Stonecraft Feb 26 at 12:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.