1

I'm trying to use an Asus USB Bluetooth Dongle in OpenSUSE. Unfortunately when I plug it in, dmesg gives me the following output:

usb 8-2: new full speed USB device using uhci_hcd and address 3
usb 8-2: New USB device found, idVendor=0cf3, idProduct=3000
usb 8-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
ath3k: probe of 8-2:1.0 failed with error -5

lsusb gives the following output:

Bus 005 Device 004: ID 0cf3:3005 Atheros Communications, Inc.

The modules ath3k and bluetooth are loaded, but neither bluedevil nor the OpenSUSE bluetooth adapter tool detect the stick.

I'm using the 2.6.37.6-0.20-desktop kernel from the OpenSUSE repositories under openSUSE 11.4 32bit. The following packages are installed:

  • bluedevil
  • bluez
  • bluez
  • compat
  • bluez-firmware
  • bluez-gstreamer
  • bluez-hcidump
  • bluez-test
  • gnome-bluetooth
  • libbluedevil1
  • libbluetooth3
  • libgnome-bluetooth8
2

After some searching I found out, that obviously the firmware for the ath3k chip on the dongle was missing. This was indicated by "/dev/.udev/firmware-missing/ath3k-1.fw". In the wireless section of kernel.org I found a git repository that contains that missing firmware image.

After copying ath3k-1.fw to "/lib/firmware" the stick was recognized without further changes to the system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.