0

I'm trying to install git on a college server, just for my user, but for some reason I can't compile it. I tried the latest version on github, as well as a couple random older versions from both github and kernel.org

Running make configure results in this

I was able to compile zsh from source without any issues, so at least make seems to work correctly

Output of uname -a:

OpenBSD [redacted host name] 6.0 GENERIC.MP#2319 amd64

gcc -v:

Reading specs from /usr/lib/gcc-lib/amd64-unknown-openbsd6.0/4.2.1/specs
Target: amd64-unknown-openbsd6.0
Configured with: OpenBSD/amd64 system compiler
Thread model: posix
gcc version 4.2.1 20070719

EDIT: After some time of trying to get git to work, I give up (at least for now). I'm going to ask the admins to install git, but in the meantime I'll have to use workarounds, like downloading zip files from GitHub, instead of cloning.

1

make is not universal.

The Makefile that you are using is specific to the GNU make program. You are using OpenBSD's make program, derived from Adam de Boor's pmake. They have quite different syntaxes.

If you build git from the OpenBSD ports tree in /usr/ports/devel/git, you'll find that this, and other stuff, has all been worked out for you.

0

From looking the errors in your question, it seems steps are missing, liking doing the autoconf or the actual configure. (e.g. the compiler is complaining of missing variables).

Looking at the official git github page, Compiling git

The actual steps to compile git, are:

autoconf
./configure
make && make install

I advise there are not generic one-fit-all procedures to compile software from source, whilst there are some common procedures, so it is always advised to look for specific instructions how to build a particular package.

PS. autoconf creates the ./configure file.

  • It seems like I don't have autoconf installed, and there is no ./configure in git-2.21.0 source. – killermenpl Feb 25 at 17:57
  • You can always try to compile autoconf... It is the one responsible for creating the ./configure file. Would not be easier to ask helpdesk for the git command? – Rui F Ribeiro Feb 25 at 17:59
  • 1
    I would suggest asking the sysadmin to install a newer version of git and to upgrade the OpenBSD installation in the process. – Kusalananda Feb 25 at 18:01
  • @Kusalananda Indeed, considering 6.4 was released October.... – Rui F Ribeiro Feb 25 at 18:02
  • @RuiFRibeiro I tried compiling autoconf from source (I also had to compile m4, since it was out of date), but it didn't work. I'm going to try using the ports tree JdeBP mentions and see what I can do. Worst case scenario I'll ask the admins if they would install git for me. They apparently installed tmux, so who knows – killermenpl Feb 25 at 18:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.