5

I installed dolphin (18.12.2-1) as file manager (for most the things I use "ls" but sometimes a preview is helpful) in i3wm on an Archlinux and would like to be able to change the background color or the font color of it.

I had once an application which I am not able to find anymore with which I was able to setup the theme for Okular (some dark theme) but I forgot its name and because kde/qt seems not to be part of its name I am not able to find it anymore. But still I would like to keep the dark theme but still solve the dolphin problem because white on white is not readable especially not if the two white colors are exactly the same.

4 Answers 4

3

Had the same issue. Fixed it with hint from ArchWiki ( https://wiki.archlinux.org/title/Dolphin#Mismatched_folder_view_background_colors )

When running Dolphin under something other than Plasma, it is possible the background color in the folder view pane will not match the system Qt theme. This is because Dolphin reads the folder view's background color from the section in ~/.config/kdeglobals

Added to ~/.config/kdeglobals

[Colors:View]
BackgroundNormal=#31363B
1

I somehow fixed it by adding a new stylesheet in qt5ct, with the content below:

QMenuBar {
}

This above code pretty much does nothing. And I'm pretty sure any selector would work. But I am not sure why adding a simple blank CSS definition would fix the problem.

Before:

enter image description here

After:

enter image description here

enter image description here

I'm on Ubuntu 18.04 using Gnome 3 desktop environment with adwaita-qt built from source as Qt5 style.

0

I was using "qt5ct" to change the theme and I just activated in this configuration tool all available style sheets now the background in dolphin is dark/black and I can read the text underneath the icons. Everything else seems to stay unchanged.

The options under style sheets are:

  • fusion-fixes.qss
  • scrollbar-simple.qss
  • sliders-simple.qss
  • traynotification-simple.qss
0

On Gnome 41.2, what worked for me was a mix of user onetusers' answer and user Silence and I's answer. I followed those steps:

  1. I added in /etc/environment the line:

    QT_QPA_PLATFORMTHEME='qt5ct'
    

    so that the qt apps use the qt5ct app settings (if you do not do that qt5ct will complain that this variable's value is currently gnome). This made most of the app be dark except for the view pannel which was white with light font.

    By this point Dolphin looked like this:

    Dolphin screenshot

    If I clicked slipt I got:

    Dolphin screenshot after clicking slipt

  2. I added these lines

    [Colors:View]
    BackgroundNormal=#2E2E2E
    

    to the file ~/.config/kdeglobals. This made the background dark so I could then read the files names which are displayed in a light color.

    Dolphin screenshot with dark background

    Remark:: the color used here is different from user onetusers' answer because ze suggested a blueish dark gray color (#31363B) while I used pure dark gray (#2E2E2E) which I color picked from the background of the Nautilus files app with the adwaita dark theme enabled.

    There still remained a blue border around the view (If you have two dolphin tabs in split view, the color we picked and the blue border appear only in the focused tab. #2E2E2E makes the focused tab stand out by being darker and it seems enough for me and more inline with the default files manager. IMO the blue border and blueish hue to the background are superfluos and detract from the overall theme). So I did the following step.

  3. Through qt5ct, I applied the style sheet fusion-fixes.qss so that the blue borders disappear (The sheet is already there you need only check the box and apply).

    This gave me this look:

    Dolphin screenshot after applying stylesheet

    which is similar to Nautilus:

    Nautilus screenshot

    Remark: I did all of this on Arch Linux 5.15.10 having installed the packages qt5ct 1.5-1 and gnome-themes-extra 3.28 (so that I could set the adwaita dark theme via gnome tweaks).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.