3

Background

I have been using Linux Mint KDE v17.3 (Plasma v4.13.2) for a number of years. I keep Firefox open in one virtual desktop and Thunderbird open in another. If I receive an email in Thunderbird containing a link and click on the link, the link opens in Firefox and Plasma automatically switches desktops to view it.

Symptom

I just installed Kubuntu 18.04 with Plasma 5.12.7. It behaves differently, and it looks like recent Plasma versions on other distros are similar.

  • With the same virtual desktop setup, clicking a link in Thunderbird opens the link in Firefox but does not switch desktops. The Task Manager icon changes color to indicate the activity on the other desktop, but you need to manually switch desktops to view it.
  • If Firefox is not already open, clicking the link in Thunderbird will launch Firefox (or a different browser if selected), in the same desktop as Thunderbird and switch focus to the browser. Similarly, if the browser is already open in the same desktop, focus will switch to it.

The only difference in behavior is that Plasma will no longer switch desktops if needed to make the browser visible.

Additional testing

  • I've tested the behavior on two computers and a number of other distros using recent versions of Plasma (Mint 19 with the Kubuntu's Plasma 5.12.7 desktop, Neptune [KDE 5.12.7 on Debian], openSUSE v42.3 w/Plasma 5.8.7, Manjaro w/Plasma 5.15.0). They all behave the same way as Kubuntu. I also tested it in a live session of KDE Neon v5.12.4 and that behaved the same way.
  • I've also tested this with sources of links other than Thunderbird and with other browsers and the behavior is the same.
  • The style of desktop arrangement (grid, cube, etc.), and type of switching animation have no effect on the symptom.

So the source appears to be recent versions of Plasma. It isn't clear whether this is new intended behavior for Plasma or a bug. I couldn't find any references to this behavior in online searches.

Is there a way to restore the previous behavior of automatically switching desktops?

  • KDE totally breaks everything on every major version change, then they slowly start rebuilding the broken features people miss, until by version maybe 12 of the new major release it starts to faintly resemble the old version, but it's never all feature complete. I stopped using KDE when 5.x came out for this reason, no fun playing that game every major release. I don't remember that feature however from 3.x or 4.x, must not have been a default. I wouldn't hold my breath. – Lizardx Feb 24 at 2:19
  • @Michael-Hampton, thanks for posting the bounty. I've done a little research since posting this question (no solution). I actually couldn't find any documentation that the automated desktop switching was ever an explicit feature. In fact, I couldn't find it even mentioned in any KDE material. It's possible that it simply worked that way as an unanticipated benefit until some unrelated recent change killed that behavior. Across DEs, it's by no means universal behavior (it's the exception rather than the rule). (cont'd) – fixer1234 May 13 at 1:25
  • Logically, it would be controlled by the window manager, and most DEs use different WMs. It is intuitive, desirable behavior, so it's surprising that it isn't a standard feature everywhere. Maybe the fact that it isn't reflects some difficulty implementing it. But it sure would be great to find a solution. – fixer1234 May 13 at 1:25
  • 1
    throwing the rock at KDE is easy ! KDE is an amazing desktop and the ONLY desktop that come with so much features and possibilities ! ... i am posting the solution to your question – intika May 13 at 14:25
3
+50

KDE Desktop Switching

Your problem is underlaid with the "focused" window situation, nothing changed on the new version of KDE but new features have been added (i am referring to the changes done to the focus stealing feature)

What's happening is when your window is activated, as it was not activated by an "active selection" it does not get the focus and thus the desktop is not automatically switched.

Solution

Change the Focus stealing prevention settings to none and your problem will be fixed

Open/run systemsettings5 > Window Management > Window Behavior > Set focus stealing prevention to none

Alternative solution

Focus stealing feature can be set on per window/application: right click on the title bar of firefox for instance and select "More actions" > "Special window settings" then in "apparence & fixes" you can customise the focus stealing setting for firefox.

With this solution you could keep the focus stealing prevention feature and also the old behavior. Also in the same setting location you can set firefox to always start on a specific desktop if this would match your needs

  • This fixed it for me. Thank you! – Michael Hampton May 13 at 15:58
  • Fantastic! This fixed it for me, also. Just FYI, focus stealing prevention isn't new; I found articles describing it in 2012 in relation to KDE4. Perhaps what changed is the default setting (it was set to Low). It's possible that there is a trade-off in fixing the problem. The purpose of the setting is to prevent pop-ups and other unwanted activity from stealing focus. So fixing this problem might leave the problem for which focus stealing prevention was initiated. If any readers want more info, see docs.kde.org/trunk5/en/kde-workspace/kcontrol/windowbehaviour. – fixer1234 May 13 at 17:58
  • 1
    The Alternate solution may be the ideal one, since it limits the action to Firefox (or whatever is the default browser). – fixer1234 May 13 at 18:04
  • 1
    Yes the feature is not completely new but it have been improved a lot (many changes) phabricator.kde.org/search/query/eQuSKMvPOPoo it's more logical that we prevent focus stealing on an action triggered by a background application when the feature is enabled... so i guess that the old version of the feature was mal functioning and now that it have been fixed; if we are not aware of what's going on, we may consider the "fix" a bug or a regression but its not :) – intika May 13 at 18:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.