58

This error shows up everytime I install Kali Linux, whenever I try to boot it. Then, it dissapears and the screen blacks out. The error is the following:+[drm:vmw_host_log [vmwgfx]] *ERROR* Failed to send host log message.

Here's also an screenshot of the error: enter image description here

3
  • 1
    Can you change to a different tty? What virtualization solution are you using?
    – kemotep
    Feb 25, 2019 at 14:24
  • found answer in this post askubuntu.com/a/817660/714051
    – Ivan Kush
    Nov 26, 2019 at 15:54
  • I had the same issue, the problem what that I allocated 64MB video memory and my device couldn't handle that in that time, so I reduced it to 32MB and it was fine then May 27, 2020 at 16:31

4 Answers 4

67

enter image description here

Try to change display setting and check

4
  • 8
    @Harikrisnan C I can confirm that changing my Graphics Controller from VMSVGA to VBoxVGA succeeded in getting my Ubuntu VM to boot without the aforementioned error. However, why did this work? Could you add the reason for this suggestion in your answer please and thank you? :)
    – z.karl
    Dec 17, 2019 at 18:01
  • 1
    When I change in Linux Mint 19.1 Mate per your suggestion, I get this message, "This VM is configured to use 3D acceleration using the VBoxVGA graphics controller. Support for this will be removed with version 6.1.0. ALL saved states and snapshots will cease to work when using this configuration. Either switch to the VMSVGA graphics controller and update guest additions, or disable 3D acceleration." Jan 15, 2020 at 23:43
  • This solution prevents 3D acceleration within the guest OS. Is the error serious enough to warrant this, or is it just a logged error? What is the error from? Aug 5, 2020 at 11:06
  • This does not work in my case. I succeeded however by booting a previous kernel and not changing the graphics setting. See also: askubuntu.com/questions/1284588/….
    – Will
    Dec 23, 2020 at 7:37
3

I had the same issue installing on Windows 10. I followed the instructions in this video:

https://tr-my.net/watchvideo/how-to-install-kali-linux-on-virtualbox-exdj6PNPuxA.html

...and it seems to work now. Note, I still see those messages ("Failed to send host log message") but it boots all the way into Kali now and I do not have further issues.

Essentially what it boiled down to was a lack of resources. I allocated 2 CPU's, 2 gig of memory, and 16 gig on the virtual HD for it to work.

Also make sure you have virtualization enabled in BIOS.

2

I've had the same problem today, on my Mac (not sure which host system you're working on).

The fix for me, as suggested on another forum was to downgrade to VirtualBox v5.2. Seems it has been an issue for some Mac users since last yeat.

2

This is a bug of VMSVGA which is waiting for the upstream fix. Check these websites for more information:
https://www.virtualbox.org/ticket/19168#comment:4
https://forums.virtualbox.org/viewtopic.php?t=101326

To fix this, if you are not using gui (like gnome,kde), you can just add nomodeset to the kernel boot parameters, to disable VMSVGA on boot.

#debian 11
#/etc/default/grub

GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset"

update-grub

If you are using gui, just ignore the message, it's not a real error.

By the way , VBoxVGA and VBoxSVGA is abandoned in the latest version of virtualbox (6.1).

1
  • 1
    Minor clarification: I am running VirtualBox 6.1 - and VBoxVGA and VboxSVGA are still available in the drop-down for display settings - however if you choose them, VirtualBox will show a tiny tiny note that there is an error in your configuration - warning that your selection is not the optimal selection for your VM.
    – qxotk
    Jan 6 at 23:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.