1

I'm working on Fedora 29 x86_64 fully patched. I'm trying to add my user to the dialout group so I can open the modem:

$ ls -Al /dev/ttyUSB0
crw-rw----. 1 root dialout 188, 0 Feb 22 19:27 /dev/ttyUSB0

$ sudo usermod -a -G dialout jwalton
(Fri Feb 22 19:32:11:373072 2019) [sss_cache] [confdb_get_domains] (0x0010): No
domains configured, fatal error!
Could not open available domains
usermod: sss_cache exited with status 2
usermod: Failed to flush the sssd cache.

According to the Fedora boards at Error when inserting user in a group, one can remove SSSD. This is where the confusion arises.

The Fedora message does not state why SSSD is installed or why it is not configured to allow one to modify groups. In addition removing SSSD looks heavy weight to me.

And according to the sssd(8) man page, "SSSD provides a set of daemons to manage access to remote directories and authentication mechanisms." The description makes SSSD's role even more confusing since sudo works and I'm not doing anything with remote directories.

I'd like to know if there is a way to modify a user's groups without uninstalling software or configuring software. I guess I'd like to know how to go back to the old days where things "just worked" as expected.


$ sudo yum remove sssd
Dependencies resolved.
================================================================================
 Package                Arch       Version                   Repository    Size
================================================================================
Removing:
 sssd                   x86_64     2.0.0-5.fc29              @updates      34 k
Removing unused dependencies:
 adcli                  x86_64     0.8.2-2.fc29              @fedora      265 k
 c-ares                 x86_64     1.13.0-5.fc29             @fedora      221 k
 cyrus-sasl-gssapi      x86_64     2.1.27-0.3rc7.fc29        @fedora       41 k
 libdhash               x86_64     0.5.0-41.fc29             @fedora       60 k
 libipa_hbac            x86_64     2.0.0-5.fc29              @updates      61 k
 libsss_autofs          x86_64     2.0.0-5.fc29              @updates      65 k
 libsss_certmap         x86_64     2.0.0-5.fc29              @updates     119 k
 libsss_idmap           x86_64     2.0.0-5.fc29              @updates      77 k
 libsss_nss_idmap       x86_64     2.0.0-5.fc29              @updates      89 k
 libsss_sudo            x86_64     2.0.0-5.fc29              @updates      58 k
 python3-sssdconfig     noarch     2.0.0-5.fc29              @updates     185 k
 sssd-ad                x86_64     2.0.0-5.fc29              @updates     377 k
 sssd-client            x86_64     2.0.0-5.fc29              @updates     249 k
 sssd-common            x86_64     2.0.0-5.fc29              @updates     4.9 M
 sssd-common-pac        x86_64     2.0.0-5.fc29              @updates     247 k
 sssd-ipa               x86_64     2.0.0-5.fc29              @updates     708 k
 sssd-krb5              x86_64     2.0.0-5.fc29              @updates      83 k
 sssd-krb5-common       x86_64     2.0.0-5.fc29              @updates     292 k
 sssd-ldap              x86_64     2.0.0-5.fc29              @updates     141 k
 sssd-nfs-idmap         x86_64     2.0.0-5.fc29              @updates      41 k
 sssd-proxy             x86_64     2.0.0-5.fc29              @updates     138 k

Transaction Summary
================================================================================
Remove  22 Packages

Freed space: 8.4 M
Is this ok [y/N]: N
  • Including the contents of sssd.conf in your system might help reproduce this issue... – filbranden Feb 23 at 6:31
  • Thanks @filbranden. A sudo find /etc/ -name sssd.* returns 0 results. – user56041 Feb 23 at 6:35
  • I could not take it anymore... I had to remove SSSD. Now open in the Fedora bugzilla: Issue 1680446, SSSD does not allow usermod to add a user to a group. – user56041 Feb 25 at 3:40
  • Good call, hopefully you'll get a useful response there. If you're not using remote accounts (LDAP, AD, etc.) then sssd isn't really doing much important on your system... It still should work, but you won't miss it in that case. Good luck with the Bugzilla! – filbranden Feb 25 at 3:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy