-1

I had hard drive which was target location for CCTV, connected to linux mini pc running rsync in background to collect footage from few locations.

Well, I noticed that sometimes rsync failed due permission error and drive got unmounted by system, it happen few times but after reboot it was working fine, I decided to copy it to new drive, when I started copying on new - it seems it died. It didn't even had 1 full year of work time, around 7 months only.

Not seen in fdisk, not seen in df.

[  166.630651] usb 1-1.3: new high-speed USB device number 5 using dwc_otg
[  166.764048] usb 1-1.3: New USB device found, idVendor=0bc2, idProduct=ab44
[  166.764067] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  166.764078] usb 1-1.3: Product: Backup+ Hub
[  166.764088] usb 1-1.3: Manufacturer: Seagate
[  166.764098] usb 1-1.3: SerialNumber: 01CB7506B0MC
[  166.767450] hub 1-1.3:1.0: USB hub found
[  166.768127] hub 1-1.3:1.0: 3 ports detected
[  167.080564] usb 1-1.3.1: new high-speed USB device number 6 using dwc_otg
[  167.212743] usb 1-1.3.1: New USB device found, idVendor=0bc2, idProduct=ab38
[  167.212755] usb 1-1.3.1: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[  167.212762] usb 1-1.3.1: Product: Backup+ Hub BK
[  167.212769] usb 1-1.3.1: Manufacturer: Seagate
[  167.212776] usb 1-1.3.1: SerialNumber: 01CB7506B0MC
[  167.214136] usb-storage 1-1.3.1:1.0: USB Mass Storage device detected
[  167.215125] scsi host0: usb-storage 1-1.3.1:1.0
[  168.251708] scsi 0:0:0:0: Direct-Access     Seagate  Backup+ Hub BK   D781 PQ: 0 ANSI: 6
[  168.255463] sd 0:0:0:0: [sda] Spinning up disk...
[  168.266405] sd 0:0:0:0: Attached scsi generic sg0 type 0
[  168.351029] usb 1-1.3-port2: Cannot enable. Maybe the USB cable is bad?
[  224.411031] ready
[  224.411442] sd 0:0:0:0: [sda] Very big device. Trying to use READ CAPACITY(16).
[  224.411842] sd 0:0:0:0: [sda] 15628053167 512-byte logical blocks: (8.00 TB/7.28 TiB)
[  255.340667] usb 1-1.3.1: reset high-speed USB device number 6 using dwc_otg
[  260.510807] usb 1-1.3.1: device descriptor read/64, error -110

Cable is okay, I tried replacing it. I did even tear plastic cover aparat, I did checked SATA connections, I tried connecting it directly in PC on Windows - disk didn't show up in disk manager interface either. Disk is bit vibrating, but it wasn't the quiet one from beginning. Now when connected, after some time it makes weird short "ding,ding,ding" sound and stops, then again vibrating.

Can someone advise whether data is lost or is there any chance ? I'm not sure how to interpret the error from dmseg. I never had disk "die" in this way, I'd also appreciate someone explaining what actually might have happened.

  • Given that you only see USB error messages, and googling for dwc_otg shows it's a non-standard driver which apparently needs some fiddling from time to time, and assuming you have a standard USB external hard driver, I'd (1) connect it to another Linux system with standard EHCI USB ports (Windows won't help unless you have a FAT filesystem on it, which would be unusual), and (2) take the drive out of the enclosure, connect it directly via SATA to avoid problems with the USB-SATA bridge chip in the enclosure. – dirkt Feb 23 at 21:03
  • Oh dear → it makes weird short "ding,ding,ding" sound and stops. – roaima Feb 27 at 15:51
  • Here is a collection of sounds failing hard drives might make. From your description, it seems the disk might be spending a long time trying to start up, but failing. – telcoM Mar 4 at 9:16
0
  1. The drive lost connection with the system before the kernel had a chance to check whether there was a partition table.

  2. Weird sounds are usually not an indication of things running entirely smoothly

    ⇒ Either the drive or the converter is dying.

  3. Windows didn't manage to find the drive with a direct SATA connection

    ⇒ it's more likely the drive.

Connecting it via SATA to a Linux box, that should be able to give you further information about what happened to it – when you connect it with a USB cable the SATA communication is going to be shielded from the kernel by the USB converter to which the disk is attached (and you won't be able to tell whether it is just the controller or the drive itself failing).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.