0

I have a sony VPCSA36GG. Being an old laptop, it used to have 4x64 ssd's with a raid 0 on it. I had problems installing grub bootloader while installing debian (my 1st linux install) so removed the raid and just installed it on one of the 64gb sticks. ( /dev/sda1)

fdisk shows each stick as a separate device. (a,b,c,d)

I have been trying to install arch on ( /dev/sdc) and am faacing the following problem.

  1. grub wont install on /dev/sdc1 (boot partition), so I had to install it on /dev/sdc. Could anyone explain why is this the case?

  2. the command

    grub-mkconfig -o /boot/grub/grub.cfg

    returns the following

    WARNING: Device /dev/sda1 not initialized in udev even after waiting 1000000 microseconds

    this warning is shown for all the devices/partitions on the laptop. How can I troubleshoot this? I turn on my laptop and it boots straight to debian. How can I get it to boot arch also?

  3. Since grub2 has already been installed with debian, why do I need to install it again while installing arch? How do I go about configuring dual boot with arch/debian?

Note: Debian is my main workhorse, has all my data. I'm only installing arch to understand how things work. I have gone through arckwiki twice now, and i still dont understand how to work around this.

  • Have you tried booting up in debian and running update-grub as root? The OS Prober can often find other installs of linux. If it can then you don't need to re-install grub. I've never tried this with arch linux though – Philip Couling Feb 22 at 20:37
  • Maybe you could narrow down each of your problems to deal them one by one? – jdwolf Feb 22 at 23:28
0
  1. If the volumes are MBR instead of GPT then GRUB has to be embedded in the MBR unless there is a BIOS boot partition. Not a partition marked as bootable but a partition specifically for a boot loader.

  2. When a software raid is used the OS still sees each of the devices. The error message indicates the volumes are not setup correctly. You probably need the volumes for the softraid and thats why it doesn't work.

  3. You don't and I would generally recommend not overwriting one distros boot loader for another. The rule of thumb for GRUB is if the distros use different /boot directories don't combine their GRUB installs. You can either use the UEFI to load them. You can install rEFInd which can load the EFI capable boot loaders like GRUB. Or you can manually install and configure Grub to chainload the other GRUBs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.