1

I have to perform update on hasnoinet server.

I created the ssh tunnel on hasnoinet box and ensured that it works:

ssh -D 1080 hasinternet
curl --socks5-hostname localhost:1080 google.com

I defined http proxy in 2 ways:

export http_proxy=http://localhost:1080/
export HTTP_PROXY=http://localhost:1080/
export FTP_PROXY=http://localhost:1080/

or

export http_proxy=socks5h://localhost:1080
export HTTPS_PROXY=socks5h://localhost:1080
export ALL_PROXY=socks5h://localhost:1080

I unable to use curl google.com and as result yum update fails. I am using EL6 Redhat.

  • I don't understand why are you setting the proxy for HTTP over SSH. – Bart Jul 27 at 19:26
  • 1
    The original poster is trying to update a server that has no direct internet connectivity, and is trying to supply the missing connectivity by proxying the connections with SSH dynamic SOCKS5 forwarding through another host that has the necessary connectivity. See this answer: EL6's libcurl may have a bug that breaks YUM-over-socks5. – telcoM Jul 27 at 22:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.