0

I have Opensuse Tumbleweed with all the latest updates installed on my laptop and my PC, on my laptop with same font CURLY BRACKET SECTION symbols are rendered, but on my PC they are not, I see only weird block symbol you usually see when font does not have the symbol in question.

I did verify that I have that same font and that same version of the font on both systems and $LANG is also the same (en_GB.utf8)

I also looked through all the fonts installed on my system via kcharselect and all of them display some kind of placeholder instead of these symbols.

  • From my experience this issue has nothing to do with the locale of the system. Switched locales problem persists. – Cosmonauth Aug 11 at 6:04
  • @Cosmonauth yes, I've just posted an answer. The problem was missing font. – Czar Aug 11 at 8:01
0

After some additional research and getting advice from online communities, I've found out that my premise was wrong. The symbols are not available in the font I thought they were coming from.

The system which was displaying the symbols correctly was just falling back to a font which was installed there and wasn't installed on my PC.

This is the command which helped to identify which:

FC_DEBUG=4 pango-view -q -t '⎱' 2>&1 |grep -o 'family: "[^"]\+' | cut -c 10- | tail -n 1

The font turned out to be FreeMono.

The symbol is the one quoted after -t parameter.

Also answers from this question helped: https://superuser.com/questions/876572/how-do-i-find-out-which-font-contains-a-certain-special-character

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.