0

My httpd is running with a daemon user. I want to do a wget using php from FTP server. When I run the php from linux server, the same downloads the required file from FTP. But when I call the same php from browser, it does not download the file. On checking the logs of of apache2, I found the below error message.

wget: /opt/lampstack-5.6.31-0/common/lib/libcrypto.so.1.0.0: no version information available (required by wget)
wget: /opt/lampstack-5.6.31-0/common/lib/libssl.so.1.0.0: no version information available (required by wget)
wget: /opt/lampstack-5.6.31-0/common/lib/libssl.so.1.0.0: no version information available (required by wget)

Can I know how to run wget and download required file to overcome this error?

  • You have libcurl in php, no need to call wget – Rui F Ribeiro Feb 18 at 8:08
  • but will it allow me to download the file from ftp? I am calling the same via browser – Programmer Feb 18 at 8:27
  • What browser are you using? – ctrl-alt-delor Feb 18 at 9:15
  • I am using chrome – Programmer Feb 18 at 9:16
  • I have wrriten a javascript which will call the php using post method. That php inturn calls wget. Wanted to know how I can download the required file from FTP using wget in php. – Programmer Feb 18 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.