0

This has been happening for a while now about a month. I thought it would be fix with new updates but it didn't.

The file /var/log/Xorg.0.log.old has this last few lines before the crash

[574.086] (II) NVIDIA(GPU-0): Deleting GPU-0
[574.087] (WW) xf86CloseConsole: KDSETMODE failed: Input/output error
[574.087] (WW) xf86CloseConsole: VT_GETMODE failed: Input/output error
[574.087] (WW) xf86CloseConsole: VT_ACTIVATE failed: Input/output error
[574.088] (II) Server terminated successfully (0). Closing log file.

I tried opening up the virtual terminal but won't let me type (It's stuck) So how can I fix it?

  • Check to see if a file /var/log/Xorg.0.log was written at the time it failed. If so, then it may contain useful information. But be aware that the file may be from a previous boot and only indicate success, so check its timestamp. Such a file from the successful boot would not be useful. – Michael Hampton Feb 18 at 15:07
  • @MichaelHampton Sorry man... it gets changed after the successful boot from 4.19 – Saeesh Tendulkar Feb 18 at 15:20
  • Then try the unsuccessful boot, and see if the file is changed. – Michael Hampton Feb 18 at 15:20
  • @MichaelHampton I did the unsuccessful boot first and then restarted for the successful boot to check the file. But the file has the success boot time. What else can I do? – Saeesh Tendulkar Feb 18 at 15:38
  • In that case the file might be renamed to /var/log/Xorg.0.log.old. – Michael Hampton Feb 18 at 15:39
0

I also stuck at the started GNOME display manager... today.

However, I solved my own problem by removing gdm and installing lightdm, which give me a good look in the start session. I've also re-install the nvidia driver but I can not tell which part really help (Maybe both of them).

Here is the command line I used to solve it...

PS: I also add nouveau.modeset=0 in /boot/grub2/grub.cfg but it gives no luck (but better resolution)

dnf remove gdm-1:3.30.1-2.fc29.x86_64 
dnf -y install lightdm-gtk
dnf -y remove nvidia-*
sudo dnf -y install akmod-nvidia xorg-x11-drv-nvidia-cuda xorg-x11-drv-nvidia-libs
sudo systemctl enable lightdm

You may check by start the lightdm immediately

systemctl stop gdm
systemctl start lightdm

Now I am totally fine without re-install the whole system as I did last time.

New contributor
MTP1984 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • I solved the problem by installing windows.Didn't want to but I had no choice – Saeesh Tendulkar Apr 15 at 8:00
  • You can study what gnome display manager and lightdm is, and then you will know why this can be applied. – MTP1984 Apr 16 at 6:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.