0

I have small Pegatron PC with Linux. When I was using Windows 7, reboot worked correctly. I migrated to CentOS, everything works except #reboot. Computer is never turned off, it simply stops responding and stop accessing HDD (turning power off on and finishes reboot, but I need this to happen naturally). How can I solve it? Tried shutdown -r and systemctl reboot, but they behave same way.

  • Does systemctl reboot work the same way for you? – Haxiel Feb 17 at 12:52
  • @Haxiel, answered – stiv Feb 17 at 13:17
0

First install acpid

yum -y install acpid
systemctl start acpid
systemctl enable acpid

Then edit /etc/default/grub to include acpi=force reboot=warm in the end of the existing GRUB_CMDLINE_LINUX=.

Rebuild grub config:

grub2-mkconfig -o /etc/grub2.cfg
  • this doesn't help, same behaviour – stiv Feb 17 at 15:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.