0

I want to share files between my 2 systems, Debian and Windows 10. I have Debian on an SSD, Windows on another and an HDD for sharing files.

But I have a problem, when I'm on Windows and I put a file on the HDD, I can see it on Debian but when I do the same when I'm on Debian, I can't see on Windows and when I'm back to Debian, the file is gone.

HDD is always connected (it's an internal HDD). On Debian, I mount the HDD and I simply copy the files and I unmount the HDD and I turn OFF the computer. Then I turn ON the computer, log to Windows and the file is not here. So I log back to Debian, I mount the HDD and the file is gone. All I do is copy nothing more.

The target is the last line: sdb1

TARGET                                SOURCE      FSTYPE  OPTIONS
/                                     /dev/sdc2   ext4     rw,relatime,errors=rem
├─/sys                                sysfs       sysfs   rw,nosuid,nodev,noexec
│ ├─/sys/kernel/security              securityfs  securit rw,nosuid,nodev,noexec
│ ├─/sys/fs/cgroup                    tmpfs       tmpfs   ro,nosuid,nodev,noexec
│ │ ├─/sys/fs/cgroup/systemd          cgroup      cgroup  rw,nosuid,nodev,noexec
│ │ ├─/sys/fs/cgroup/perf_event       cgroup      cgroup  rw,nosuid,nodev,noexec
│ │ ├─/sys/fs/cgroup/pids             cgroup      cgroup  rw,nosuid,nodev,noexec
│ │ ├─/sys/fs/cgroup/cpuset           cgroup      cgroup  rw,nosuid,nodev,noexec
│ │ ├─/sys/fs/cgroup/freezer          cgroup      cgroup  rw,nosuid,nodev,noexec
│ │ ├─/sys/fs/cgroup/cpu,cpuacct      cgroup      cgroup  rw,nosuid,nodev,noexec
│ │ ├─/sys/fs/cgroup/net_cls,net_prio cgroup      cgroup  rw,nosuid,nodev,noexec
│ │ ├─/sys/fs/cgroup/memory           cgroup      cgroup  rw,nosuid,nodev,noexec
│ │ ├─/sys/fs/cgroup/blkio            cgroup      cgroup  rw,nosuid,nodev,noexec
│ │ └─/sys/fs/cgroup/devices          cgroup      cgroup  rw,nosuid,nodev,noexec
│ ├─/sys/fs/pstore                    pstore      pstore  rw,nosuid,nodev,noexec
│ ├─/sys/firmware/efi/efivars         efivarfs    efivarf rw,nosuid,nodev,noexec
│ ├─/sys/kernel/debug                 debugfs     debugfs rw,relatime
│ └─/sys/fs/fuse/connections          fusectl     fusectl rw,relatime
├─/proc                               proc        proc    rw,nosuid,nodev,noexec
│ └─/proc/sys/fs/binfmt_misc          systemd-1   autofs  rw,relatime,fd=27,pgrp
│   └─/proc/sys/fs/binfmt_misc        binfmt_misc binfmt_ rw,relatime
├─/dev                                udev        devtmpf rw,nosuid,relatime,siz
│ ├─/dev/pts                          devpts      devpts  rw,nosuid,noexec,relat
│ ├─/dev/shm                          tmpfs       tmpfs   rw,nosuid,nodev
│ ├─/dev/hugepages                    hugetlbfs   hugetlb rw,relatime
│ └─/dev/mqueue                       mqueue      mqueue  rw,relatime
├─/run                                tmpfs       tmpfs   rw,nosuid,noexec,relat
│ ├─/run/lock                         tmpfs       tmpfs   rw,nosuid,nodev,noexec
│ ├─/run/user/117                     tmpfs       tmpfs   rw,nosuid,nodev,relati
│ └─/run/user/1000                    tmpfs       tmpfs   rw,nosuid,nodev,relati
│   └─/run/user/1000/gvfs             gvfsd-fuse  fuse.gv rw,nosuid,nodev,relati
├─/boot/efi                           /dev/sdc1   vfat    rw,relatime,fmask=0077
└─/media/pandabear/1435-BCBB          /dev/sdb1   fuseblk rw,nosuid,nodev,relati
  • 1
    We cannot guess what you are doing and how you are doing it, that may lead to that situation. The question is not answerable with this level of detail. – Rui F Ribeiro Feb 17 at 9:54
  • When I copy my files from Windows to the HDD, I can see it when I use Debian but when I use Debian and I copy a file to the HDD, I can't see the file when I use Windows. And also when I relog to Debian, the file that I just copy earlier is gone. – PandaBear Feb 17 at 10:00
  • You are just rehashing the question. Please tell us the exact detailed steps of how you create files, and what you do in the between, including what you do to take the hard disk out of the system. We need more technical details in this and future questions. Also please improve the question editing it, not in commenting. – Rui F Ribeiro Feb 17 at 10:06
  • When you are in Debian, mount the HDD, then in the terminal run findmnt. Add the output of said command to your question and specify which "target" is the one you're copying files to. – Emmanuel Rosa Feb 17 at 10:17
  • Is the HDD running NTFS? If not, what is it, and why is it mounted via FUSE? – roaima Feb 17 at 21:16
2

Sounds like you might be getting bitten by Windows Fast Startup... and since you're mounting it through FUSE (fstype is listed as fuseblk) and the volume ID is of the form xxxx-xxxx, I guess that might be an ExFAT filesystem. That might explain why you might not be getting a warning about the disk "not being cleanly unmounted" when mounting it in Linux.

The problem with Windows Fast Startup is that it uses a technique similar to hibernation: after a full reboot, it stores the system state into a file similar to hibernation file, and the next time the system is started up, instead of loading and starting all OS components piece by piece, it just restores the system state from the "hibernation" file.

The hibernation file can include parts of filesystem metadata cache, which is not a problem if Windows is the only OS on the system... but if you're dual-booting with another OS, changing the filesystems using it, and then booting back to Windows, it might use its cached filesystem metadata from the hibernation file, unaware that another OS has made changes to the disk while Windows was shut down. And if you then make any changes to the disk, it might update the filesystem based on the cached metadata, overwriting any changes you made in Linux.

So, whenever you're dual-booting with Windows 10 + some other OS, you must make a choice: either don't mount any filesystems used by Windows located on non-removable disks on the other OS, or disable Windows Fast Startup. But if you have Windows 10 on SSD, it should boot up plenty fast even with Fast Startup disabled.

Note that Windows Fast Startup is not the same thing as "Fast Boot" you might find in the BIOS settings of your system.

To disable Fast Startup:

  • Open the Start Menu.
  • Type "Control Panel" and hit Enter.
  • Go into "Power Options", then into "Choose what the power buttons do" on the left.
  • Click on "Change settings that are currently unavailable", then ensure that the "Turn on fast startup" setting is unchecked.
  • I see but now the situation has changed, when I am using Debian and I put files on the HDD, the files are still there where I relog to Debian. So now the only problem is I can't see those files when I am using Windows. I will try and see what happen. – PandaBear Feb 17 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.