0

I have nvidia driver installed in my debian 9 machine. cat /proc/driver/nvidia/version shows the following information:

NVRM version: NVIDIA UNIX x86_64 Kernel Module 384.130 Wed Mar 21 03:37:26 PDT 2018 GCC version: gcc version 6.3.0 20170516 (Debian 6.3.0-18+deb9u1)

Now I need install cuda 10, which requires nvidia driver version 410. The downloaded cuda installation package (a .run file) includes nvidia driver v410 installation. My question is: do I need do anything (such as uninstall) for my installed v384 version driver before I install the new one? or they can co-exist or the old one will be covered automatically?

I guess the v384 driver was installed by apt install nvidia-cuda-toolkit previously, which installs cuda 8.0 and nvidia driver v384. I am not sure how to uninstall old v384 driver. apt list --installed|grep nvidia in the machine shows quite some packages:

glx-alternative-nvidia/now 0.8.3~deb9u1 amd64 [installed,upgradable to: 0.8.8~deb9u2] libnvidia-cfg1/now 384.130-1 amd64 [installed,upgradable to: 390.87-8~deb9u1] libnvidia-compiler/now 384.130-1 amd64 [installed,upgradable to: 390.87-8~deb9u1] libnvidia-fatbinaryloader/now 384.130-1 amd64 [installed,upgradable to: 390.87-8~deb9u1] libnvidia-ml1/now 384.130-1 amd64 [installed,upgradable to: 390.87-8~deb9u1] libnvidia-ptxjitcompiler1/now 384.130-1 amd64 [installed,upgradable to: 390.87-8~deb9u1] nvidia-alternative/now 384.130-1 amd64 [installed,upgradable to: 390.87-8~deb9u1] nvidia-cuda-dev/stable,now 8.0.44-4 amd64 [installed,automatic] nvidia-cuda-doc/stable,stable,now 8.0.44-4 all [installed,automatic] nvidia-cuda-gdb/stable,now 8.0.44-4 amd64 [installed,automatic] nvidia-cuda-toolkit/stable,now 8.0.44-4 amd64 [installed] nvidia-detect/now 384.130-1 amd64 [installed,upgradable to: 390.87-8~deb9u1] nvidia-installer-cleanup/stable,now 20151021+4 amd64 [installed,automatic] nvidia-kernel-common/stable,now 20151021+4 amd64 [installed,automatic] nvidia-kernel-dkms/now 384.130-1 amd64 [installed,upgradable to: 390.87-8~deb9u1] nvidia-kernel-support/now 384.130-1 amd64 [installed,upgradable to: 390.87-8~deb9u1] nvidia-legacy-check/now 384.130-1 amd64 [installed,upgradable to: 390.87-8~deb9u1] nvidia-libopencl1/now 384.130-1 amd64 [installed,upgradable to: 390.87-8~deb9u1] nvidia-modprobe/now 384.111-2~deb9u1 amd64 [installed,upgradable to: 390.87-1~deb9u1] nvidia-opencl-common/now 384.130-1 amd64 [installed,upgradable to: 390.87-8~deb9u1] nvidia-opencl-dev/stable,now 8.0.44-4 amd64 [installed,automatic] nvidia-opencl-icd/now 384.130-1 amd64 [installed,upgradable to: 390.87-8~deb9u1] nvidia-persistenced/now 384.111-1~deb9u1 amd64 [installed,upgradable to: 390.87-1~deb9u1] nvidia-profiler/stable,now 8.0.44-4 amd64 [installed,automatic] nvidia-smi/now 384.130-1 amd64 [installed,upgradable to: 390.87-8~deb9u1] nvidia-support/stable,now 20151021+4 amd64 [installed,automatic] nvidia-visual-profiler/stable,now 8.0.44-4 amd64 [installed,automatic]

0

I was just looking for a similar answer. I have Debian 9 and currently have Nvidia driver 418.34 successfully installed along with CUDA 10.0 tool kit

I would first start by asking what your current GPU is? You need to make sure that your current GPU is compatible with Nvidia driver 410 (or 418.34). I also know that the two drivers (384 and 410) will not coexist together at the same time.

I recently got an RTX 2080, and Nvidia recently released the newest version of their driver (418.43). I went to the Nvidia website and downloaded their ".run" file for v418.43. I then removed the old driver (v384) using aptitude. Afterwards I tried to install the new version with the ".run" file, but it kept saying I couldn't install because I was currently using Xorg.

Try installing it by Alt + Ctrl + F2 and running the ".run" there. Try to install the new driver without rebooting.

If you reboot, you might not be able to boot after, but I have a possible solution to this if you are interested.

Once the driver was installed, you can test by running "nvidia-smi" in your terminal.

I then went to Nvidia's website to download the CUDA 10.0 ".run" file (I downloaded the one for Ubuntu 18.04).

At first the installer was saying that my configuration was not compatible and if I wanted to continue anyways. I said "yes".

I also said "Yes" to install the tool kit and the samples, but refused the nvidia driver install.

The installation finished as "incomplete", however I went to the directory it was installed in and tested it with a test cuda program and everything work perfectly.

I will continue to do testing, but as of now everything seems to work as it should.

If you run into issues with booting or GUI not loading, I might be able to help because I ran into those issues.

There is very little information out there for Debian 9 and CUDA 10.

  • It would be more helpful if you focused on the correct procedures, and left out the saga of your missteps. – G-Man Feb 25 at 2:11
  • @G-Man Thank you for your comment. I realized that I added answers to questions that were not asked. I have edited my answer to leave out the "saga of my missteps". – T. Hound Feb 25 at 3:02
  • @T. Hound, thanks. Can you tell me how did you remove the old driver? I believe my old driver was installed as a part when I installed nvidia-cuda-toolkit package. – michael morgan Feb 26 at 1:50
  • @michaelmorgan If you installed it with nvidia-cuda-toolkit, I believe you can remove it with: sudo apt-get purge nvidia-* then sudo apt-get autoremove Please try to ensure to install the new driver before you reboot. Otherwise, you might not be able to boot back in. However, I can probably help if you have no other choice. – T. Hound Feb 28 at 1:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.