I installed deepin on Arch (fresh install) and it just isn't working, I can't log in, when I start the lightdm.service, it just shows blank white screen. I haven't enable the service yet. I was just checking if it worked and its not working.


There might be an issue with the lightdm-deepin-greeter.

Install an alternative greeter, e.g lightdm-gtk-greeter

sudo pacman -S lightdm-gtk-greeter

Then edit /etc/lightdm/lightdm.conf

sudo nano /etc/lightdm/lightdm.conf

Look for the line that is like greeter-session=lightdm-deepin-greeter or the value could be something else change it to


Save, ctrl-x, y, [enter]

Stop & start the lightdm.service and see if that works.

systemctl stop lightdm
systemctl start lightdm



Hey I've ran into the same issue as you

Turn out I have not create a non root user, fixed by:

useradd -m newuser
passwd newuser
systemctl restart lightdm

then the beautiful Deepin login screen is appear! Hope you fixed it

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.