-1

This question already has an answer here:

On other distros when I open terminal, it is usually either ask for password or logs in with normal user priviliges, in Kali it logs on automatically with root. I want to stop that.

marked as duplicate by Rui F Ribeiro, Romeo Ninov, Sparhawk, Stephen Harris, DarkHeart Feb 17 at 9:10

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 6
    That's why Kali is for advanced. – Prvt_Yadv Feb 16 at 16:39
  • what do you mean ? it is not doable ? – Genghis Feb 16 at 16:45
3

From the Kali Linux Root User Policy:

Kali Linux, however, as a security and auditing platform, contains many which tools can only run with root privileges. Further, Kali Linux’s nature makes its use in a multi-user environment highly unlikely.

For these reasons, the default Kali user is “root”, and no non-privileged user is created as a part of the installation process. This is one reason that Kali Linux is not recommended for use by Linux beginners who might be more apt to make destructive mistakes while running with root privileges.

To create a non-root account, use useradd with the appropriate options. Then set the user's password using passwd. See the manuals for these two utilities. For further Kali-specific information, refer to the official Kali Linux documentation website at https://docs.kali.org/

Not the answer you're looking for? Browse other questions tagged or ask your own question.