0

I have an embedded board (NXP iMX6 sabrelite) that is attached to an LTE stick and runs an openvpn service which configures an interface (tap0) with a local IP address. The same is done for an Ubuntu running PC. The idea is to have an Ubuntu PC and the iMX6 board, exchange some data via a UDP-RTP application. Now I have the following interfaces on imx6 and Ubuntu PC:

on imx6 :

eth1: //LTE stick
inet 192.168.9.x

tap0: //open vpn configured interface
inet 192.168.2.222

on Ubuntu PC:

enx64d1a34bd419: //LTE router
inet 192.168.1.x

tap0: //open vpn configured interface
inet 192.168.2.221

The configuration file is specified here.

The configuration files for iMX6 and Ubuntu are the same except the difference in the cert and key accordingly.

Now the actual problem is I cannot do an ssh to the imx6 board from the Ubuntu PC.

root@linux-GP60-2PE:/home/linux# ssh debian@192.168.2.222
ssh: connect to host 192.168.2.222 port 22: No route to host

I can ping to the imx6 board, but not ssh. I see a number of questions that pertain to be able to ping and not ssh, but in my particualar seems to be an issue with the MTU configuration, and the openvpn configuration.

I can do an ssh with any other interface like ethernet or wifi, but not with the tap interface configured to the imx6 device.

Can anyone let me know where I am going wrong with this?

EDIT: Further debugging on the iMX6 board, using journalctl _COMM=sshd, I found the following logs:

Feb 15 03:19:09 stretch-dev sshd[1182]: debug1: Forked child 1318.
Feb 15 03:19:09 stretch-dev sshd[1318]: debug1: Set /proc/self/oom_score_adj to 0
Feb 15 03:19:09 stretch-dev sshd[1318]: debug1: rexec start in 5 out 5 newsock 5 pipe 7 sock 8
Feb 15 03:19:09 stretch-dev sshd[1318]: debug1: inetd sockets after dupping: 3, 3
Feb 15 03:19:09 stretch-dev sshd[1318]: Connection from 192.168.2.221 port 51066 on 192.168.2.222 port 22
Feb 15 03:19:09 stretch-dev sshd[1318]: debug1: Client protocol version 2.0; client software version OpenSSH_7.6p1 Ubuntu-4ubuntu0.2
Feb 15 03:19:09 stretch-dev sshd[1318]: debug1: match: OpenSSH_7.6p1 Ubuntu-4ubuntu0.2 pat OpenSSH* compat 0x04000000
Feb 15 03:19:09 stretch-dev sshd[1318]: debug1: Local version string SSH-2.0-OpenSSH_7.4p1 Debian-10+deb9u5
Feb 15 03:19:09 stretch-dev sshd[1318]: debug1: Enabling compatibility mode for protocol 2.0
Feb 15 03:19:09 stretch-dev sshd[1318]: debug2: fd 3 setting O_NONBLOCK
Feb 15 03:19:09 stretch-dev sshd[1318]: debug2: Network child is on pid 1319
Feb 15 03:19:09 stretch-dev sshd[1318]: debug1: permanently_set_uid: 106/65534 [preauth]
Feb 15 03:19:09 stretch-dev sshd[1318]: debug1: list_hostkey_types: ssh-rsa,rsa-sha2-512,rsa-sha2-256,ecdsa-sha2-nistp256,ssh-ed25519 [preauth]
Feb 15 03:19:09 stretch-dev sshd[1318]: debug1: SSH2_MSG_KEXINIT sent [preauth]

And then it blocks, with no further logs. And the following line after some time :

root@linux-GP60-2PE:/home/linux# ssh debian@192.168.2.222
Connection closed by 192.168.2.222 port 22
  • If you firewall on your server opened for your VPN IP Range? Is your VPN using IPv4 and not IPv6? – Delirium Feb 14 at 15:46
  • @Delirium I have disabled the firewall on both systems using ufw disable. I am not sure about the VPN using IPv4 or v6. I do get assigned a IPv4 address for the tap interface. How do I check this? – vk_gst Feb 14 at 16:05
  • It's not about VPN but about your internet connection setup, disable IPv6 and let your traffic go only with IPv4 – Delirium Feb 16 at 11:42
  • @Delirium I tried disabling the IPv6 as mentioned here on both iMX6 and Ubuntu PC. It didn't help, the issue still exists. – vk_gst Feb 18 at 14:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.