0

CentOS 7 kernel release 3.10.0-957.el7.x86_64 drbd 9.0.16-1

Have one resource configured. drbd servicve is not enabled to start at boot time. I reboot the two nodes. One the first node I run systemctl start drbd and get

"DRBD's startup script waits for the peer node(s) to appear.

On second now when I run systemctl start drbd I get:

drbd data: failed to create debugfs dentry

EDIT

When I run drbdadm up resource_name on both nodes with drbd service disable and not started I get the two nodes in Secondary/UpToDate state which is good.

EDIT2

global_common.conf enter image description here

data.res

enter image description here

All resource are started on otrs1. It has the Primary role bot shows connecting for the remote node, and on the remote node I don't see the other node at all.

enter image description here

When I run pcs cluster stop --all and next run drbdadm up data on both nodes all looks good.

enter image description here

Now when I mount /dev/drbd1 /opt/otrs on one of the nodes it gets auto promoted to the primary role.

enter image description here

Now when I umount and bring the reource down on both nodes and re-run drbdadm status I get obviously No currently configured DRBD found.

Now, exactly the same happens when I run systemctl start drbd on both. On first node the output appears to hand but I guess it waits for the other node to start its services as well, right ? enter image description here

After a reboot, the cluster and resources start on node 1 but after putting it into standby mode, resources are not moved:

enter image description here

And here's what I see journalctl -xe

enter image description here

EDIT3

ok that's odd

enter image description here

I was loading the drbd kernel module at boot via /etc/modules-load.d/drbd.conf on both nodes but disabled it. Rebooted and to my suprise on one node it's loaded but without drbd_transport_tcp, is pacemaker loading the drbd kernel_module? I can't imagine that.

enter image description here

Now when I systemctl disable pcsd; systemctl disable pacemaker; systemctl disable corosync on both node and reboot an do lsmod | grep drbd it returns no results. I don't get it :(

  • 1
    Can you share your DRBD configuration with us? Also, what version of kmod-drbd to you have installed? – Matt Kereczman Feb 15 at 17:26
  • @MattKereczman Thank you for looking into my issue! Please see the EDIT section of my post. Thank you! PS. kmod-drbd version is on both kmod-drbd90-9.0.16-1.el7_6.elrepo.x86_64 – blabla_trace Feb 16 at 16:55
1

If you're using Pacemaker, which you are, then you should disable DRBD in systemd, allowing Pacemaker to have full control of starting/stopping DRBD.

# systemctl disable drbd

DRBD should load it's transport modules when it brings up it's connections, and drbdadm up <res> should load the DRBD kernel module if it isn't already loaded.

  • Thank you Matt but drbd service was not running and disable on both nodes from starting during boot. What I did, I've added auto-promote no in the global_common.conf on both nodes. I also discovered that there was a spli brain condition reported journalctl | grep split. What I did next, stopped the corosync service on both nodes and followed docs.linbit.com/docs/users-guide-9.0/#s-resolve-split-brain . Was it the correct way to resolve a split brain condition ? – blabla_trace Feb 19 at 19:38
  • 1
    That is the correct way to resolve a split brain. Do you happen to have anything being "denied" in /var/log/audit/audit.log? – Matt Kereczman Feb 19 at 23:31
  • Yes, but I think this was related to selinux being enabled on node2. – blabla_trace Feb 20 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.