-2

I'm trying to install Debian and CentOS on one disk with a UEFI boot. When Debian boots, I get the error in the image below:

enter image description here

To explain how I attempted to set this up, I'll show what I did with the partitioning. Below is a picture of my initial Debian partitioning (note I left some spare space at the end to put the CentOS "/" mount point on).

enter image description here

After that ran and installed it worked fine. I then put a USB drive in, to boot and install CentOS. When I got to the partition screen, this is what it looked like (before any modification):

enter image description here

I then made one 20GiB partition for the / of CentOS. Additionally, under the Debian partition section, I modified the /boot/efi partition to have the "mount point (see far right of the image)" of /boot/efi. This then seemed to duplicate itself over to the CentOS partition section. The result is shown below: enter image description here

Upon boot, I see two options, one for CentOS and one for Debian. If I select CentOS it works fine. If I select Debian, I get the error shown in the first link of this post. My question is why?

My EFI directory is below.

[root@localhost EFI]# cd /boot/efi/EFI
[root@localhost EFI]# ls
BOOT  centos  debian
[root@localhost EFI]# ls centos debian
centos:
BOOT.CSV     fonts  fwupia32.efi  grub.cfg  grubx64.efi  MokManager.efi  shimx64-centos.efi
BOOTX64.CSV  fw     fwupx64.efi   grubenv   mmx64.efi    shim.efi        shimx64.efi

debian:
grubx64.efi

My /boot/efi/EFI/centos/grub.cfg is below:

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub2-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
set pager=1

if [ -s $prefix/grubenv ]; then
  load_env
fi
if [ "${next_entry}" ] ; then
   set default="${next_entry}"
   set next_entry=
   save_env next_entry
   set boot_once=true
else
   set default="${saved_entry}"
fi

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

terminal_output console
if [ x$feature_timeout_style = xy ] ; then
  set timeout_style=menu
  set timeout=5
# Fallback normal timeout code in case the timeout_style feature is
# unavailable.
else
  set timeout=5
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/00_tuned ###
set tuned_params=""
set tuned_initrd=""
### END /etc/grub.d/00_tuned ###

### BEGIN /etc/grub.d/01_users ###
if [ -f ${prefix}/user.cfg ]; then
  source ${prefix}/user.cfg
  if [ -n "${GRUB2_PASSWORD}" ]; then
    set superusers="root"
    export superusers
    password_pbkdf2 root ${GRUB2_PASSWORD}
  fi
fi
### END /etc/grub.d/01_users ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'CentOS Linux (3.10.0-957.el7.x86_64) 7 (Core)' --class centos --class gnu-linux --class gnu --class os --unrestricted $menuentry_id_option 'gnulinux-3.10.0-957.el7.x86_64-advanced-4b9ca680-8e47-494f-8a98-991aab9d51e6' {
    load_video
    set gfxpayload=keep
    insmod gzio
    insmod part_gpt
    insmod xfs
    set root='hd0,gpt3'
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3  4b9ca680-8e47-494f-8a98-991aab9d51e6
    else
      search --no-floppy --fs-uuid --set=root 4b9ca680-8e47-494f-8a98-991aab9d51e6
    fi
    linuxefi /boot/vmlinuz-3.10.0-957.el7.x86_64 root=UUID=4b9ca680-8e47-494f-8a98-991aab9d51e6 ro crashkernel=auto rhgb quiet 
    initrdefi /boot/initramfs-3.10.0-957.el7.x86_64.img
}
menuentry 'CentOS Linux (0-rescue-6afd59629baf4fd295f2313dd51b9e9e) 7 (Core)' --class centos --class gnu-linux --class gnu --class os --unrestricted $menuentry_id_option 'gnulinux-0-rescue-6afd59629baf4fd295f2313dd51b9e9e-advanced-4b9ca680-8e47-494f-8a98-991aab9d51e6' {
    load_video
    insmod gzio
    insmod part_gpt
    insmod xfs
    set root='hd0,gpt3'
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt3 --hint-efi=hd0,gpt3 --hint-baremetal=ahci0,gpt3  4b9ca680-8e47-494f-8a98-991aab9d51e6
    else
      search --no-floppy --fs-uuid --set=root 4b9ca680-8e47-494f-8a98-991aab9d51e6
    fi
    linuxefi /boot/vmlinuz-0-rescue-6afd59629baf4fd295f2313dd51b9e9e root=UUID=4b9ca680-8e47-494f-8a98-991aab9d51e6 ro crashkernel=auto rhgb quiet 
    initrdefi /boot/initramfs-0-rescue-6afd59629baf4fd295f2313dd51b9e9e.img
}
if [ "x$default" = 'CentOS Linux (3.10.0-957.el7.x86_64) 7 (Core)' ]; then default='Advanced options for CentOS Linux>CentOS Linux (3.10.0-957.el7.x86_64) 7 (Core)'; fi;
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/20_ppc_terminfo ###
### END /etc/grub.d/20_ppc_terminfo ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry 'Debian GNU/Linux (9.8) (on /dev/sda2)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-simple-9a0b0533-9320-45f1-9b3d-0860da8822be' {
    insmod part_gpt
    insmod ext2
    set root='hd0,gpt2'
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  9a0b0533-9320-45f1-9b3d-0860da8822be
    else
      search --no-floppy --fs-uuid --set=root 9a0b0533-9320-45f1-9b3d-0860da8822be
    fi
    linux /boot/vmlinuz-4.9.0-8-amd64 root=UUID=9a0b0533-9320-45f1-9b3d-0860da8822be ro quiet
    initrd /boot/initrd.img-4.9.0-8-amd64
}
submenu 'Advanced options for Debian GNU/Linux (9.8) (on /dev/sda2)' $menuentry_id_option 'osprober-gnulinux-advanced-9a0b0533-9320-45f1-9b3d-0860da8822be' {
    menuentry 'Debian GNU/Linux (on /dev/sda2)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-4.9.0-8-amd64--9a0b0533-9320-45f1-9b3d-0860da8822be' {
        insmod part_gpt
        insmod ext2
        set root='hd0,gpt2'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  9a0b0533-9320-45f1-9b3d-0860da8822be
        else
          search --no-floppy --fs-uuid --set=root 9a0b0533-9320-45f1-9b3d-0860da8822be
        fi
        linux /boot/vmlinuz-4.9.0-8-amd64 root=UUID=9a0b0533-9320-45f1-9b3d-0860da8822be ro quiet
        initrd /boot/initrd.img-4.9.0-8-amd64
    }
    menuentry 'Debian GNU/Linux, with Linux 4.9.0-8-amd64 (on /dev/sda2)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-4.9.0-8-amd64--9a0b0533-9320-45f1-9b3d-0860da8822be' {
        insmod part_gpt
        insmod ext2
        set root='hd0,gpt2'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  9a0b0533-9320-45f1-9b3d-0860da8822be
        else
          search --no-floppy --fs-uuid --set=root 9a0b0533-9320-45f1-9b3d-0860da8822be
        fi
        linux /boot/vmlinuz-4.9.0-8-amd64 root=UUID=9a0b0533-9320-45f1-9b3d-0860da8822be ro quiet
        initrd /boot/initrd.img-4.9.0-8-amd64
    }
    menuentry 'Debian GNU/Linux, with Linux 4.9.0-8-amd64 (recovery mode) (on /dev/sda2)' --class gnu-linux --class gnu --class os $menuentry_id_option 'osprober-gnulinux-/boot/vmlinuz-4.9.0-8-amd64-root=UUID=9a0b0533-9320-45f1-9b3d-0860da8822be ro single-9a0b0533-9320-45f1-9b3d-0860da8822be' {
        insmod part_gpt
        insmod ext2
        set root='hd0,gpt2'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  9a0b0533-9320-45f1-9b3d-0860da8822be
        else
          search --no-floppy --fs-uuid --set=root 9a0b0533-9320-45f1-9b3d-0860da8822be
        fi
        linux /boot/vmlinuz-4.9.0-8-amd64 root=UUID=9a0b0533-9320-45f1-9b3d-0860da8822be ro single
        initrd /boot/initrd.img-4.9.0-8-amd64
    }
}

### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

UPDATE - Got A Working Solution, but not happy how I got there (I would like to someone to tell me why my system ended up this way) : In my /boot/efi/EFI/centos/grub.cfg file I manually edited the lines under the Debian menu entry (or sub-menu entries) starting with the word "linux" or initrd" to the words "linuxefi" and "initrdefi" respectively. I can't understand why I've had to manually edit this grub file to make my debian system boot. I must be doing something very wrong right from the installation/setup stages of the operating systems for me to run into this problem. What is happening?

  • “ I get the error in the image below:” —There is not image below. – ctrl-alt-delor Feb 19 at 19:09
  • 1
    Click the link below and see the image. – john smith Feb 20 at 21:39
  • sorry you miss-understand me. I am not an idiot, that needs to be told where the images are. I am some one that is giving feedback on you question. To make it a better question. In the hope that someone will answer it. You need to make the images part of the question, so that it is self contained, so that a reader can read it without being sent off, and coming back, and all that effort (If you act on the feedback, then I will read the rest of the question.) – ctrl-alt-delor Feb 21 at 9:30
  • 1
    That's right, I still don't understand you. You said "You need to make the images part of the question". There is nothing more that I can do to show you the image other than give the link underneath. Like, what more are you expecting? Is there a way to make the image from the link appear within the post (if so teach me so I can do what you ask man, I have tried to do this for years, but could never figure out how, or if its possible). – john smith Feb 21 at 21:58
  • I did the first one for you. I followed the link, and right clicked to get a link to the image. Then edited question, clicked add image, and pasted the link. – ctrl-alt-delor Feb 21 at 22:56
1
+100

Looks like CentOS's /etc/grub.d/30_os-prober script failed to take into account that the CentOS GRUB uses Secure Boot-compatible linuxefi/initrdefi keywords and omits support for the traditional linux/initrd ones. (Or maybe the support would be available as a GRUB module, but Secure Boot requires all executable code to be loaded to use UEFI standard executable/library formats, which GRUB modules are not.)

Debian, on the other hand, uses the traditional linux/initrd keywords because of their strong pro-Free Software (and consequently anti-Secure Boot) stance.

CentOS's os-prober apparently just copied the configuration lines from Debian's GRUB configuration file essentially as-is, without applying the necessary change. You might file a bug report on CentOS os-prober about this, if someone hasn't already reported it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.