0

I´m installing an old accounting program in Dosemu and It runs very well until it’s time to print a report. The program checks that the printer is on-line prior to sending the information and it gives a message that no printer is available and stops (I don´t have a parallel printer in lpt1 and I’m using Cups-pdf as a way to manage the outputs)

I have set up Dosemu and Cups-pdf and I can print from the command line. Thus, the Cups configuration seems to be ok.

I tested the program with the ‘Mode lpt1=Null’ and in this case the program did send the information to the printer but since in this case the printer is ‘Null’ the report was lost.

It seems that the Dosemu default setting for the printer status register of LPT1 is ‘Acknowledge’ (INT17) and the program is waiting for a ‘Printer On-Line’. For some reason, the ‘Mode lpt1=Null’ changes this setting to ‘Printer On-Line’ which leads me to believe that there is a way to manage this setting.

How can I change this configuration? Can I do it with the runtime options or do I need to do a compilation? Maybe there is a simpler solution that I haven't considered.

I am using Dosemu 1.4.0.8, Cups 2.2.1 on a Debian 9.7 strech 64.

  • You could try dosbox instead of dosemu. This seems to have solved a similar problem here: nishadnerurkar.wordpress.com/tag/printing-in-dosbox – Bodo Feb 13 at 17:29
  • Thank you for your the link. If addresses the issue that I'm struggling with. However it seems to have been written in a old version of C++ and I'm having trouble compiling it. – Zocco Feb 15 at 19:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.