0

Following the 02/09 Tumbleweed update my DNS seems to be broken.

My wifi icon in top right has a question mark, ping google.com returns Name or service not known, but nslookup google.com correctly returns the IP address. If I go to Google's IP address in Firefox I get the message We can't connect to the server at www.google.com. so it is being resolved somehow.

I can ping 8.8.8.8.

I've tried all the other answers I can see for related issues but none have worked for me. My resolv.conf is:

search MYDOMAIN
nameserver IP1
nameserver IP2

where IP1 & 2 are my companies addresses.

I've tried changing nsswitch.conf and reduced the hosts line to files dns (removing the mdns4 bit).

If I force Google's DNS then it still doesn't work, i.e. if I try nslookup google.com 8.8.8.8 it fails, and if I go into NetworkManager and add 8.8.8.8,8.8.4.4 to DNS in IPv4 settings for my Wifi then it still doesn't work.

  • Do not use ping to troubleshoot DNS issues. The correct tool for that is dig, which is superiot to nslookup. By default it will use nameservers defined in /etc/resolv.conf so the first step is making sure you can contact them. – Patrick Mevzek Feb 14 at 23:17
2

I had a similar problem after update from Leap 15.0 to Leap 15.1: nslookup worked but ping or anything else that required dns resolution didn't. I did all the standard checks (resolv.conf, nsswitch.conf, /etc/sysconfig/network/config) and these were in order. Switching from wicked to NetworkManager and enabling dnsmasq as above solved my issue initially.

I dug a little deeper and found a tip here that it may be related to issues in apparmor configuration: https://forums.opensuse.org/showthread.php/536437-DNS-problem-after-upgrade-from-15-0?p=2906092#post2906092

Similarly to that thread on my system that there was an updated configuration in /etc/apparmor.d/abstractions/nameservice.rpmnew which allowed access to additional directories used by nscd. Once I copied over this new config file and cleared the apparmor cache as described in that post, wicked started working and I could revert my network manager config back to the original version, without needing to use dnsmasq.

  • Exactly the same thing here after the update from 15.0 to 15.1. – Claas Jul 17 at 7:32
0

I got this working by adding dns=dnsmasq under [main] in /etc/NetworkManager/NetworkManager.conf.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.