0

Just got a Brother HL-L2395, and am trying to get it printing from a "vanilla" (from an original 14.2x64 dvd) Slackware 14.2x64 install.

I first got it connected to my wifi, typing the wifi password on the printer's touchscreen keyboard. And then I pointed firefox to its assigned url, logged in, and successfully printed a test page ("user settings list") from the printer's web menu. That all seems to be working fine.

Next went to cups at localhost:631, logged in to the "add printer" page, and cups immediately identified the new L2395. I proceeded to add that, and on the next page agreed with cups that it's a Brother. Then cups presented a long menu selection of Brother ppd files, but nothing for the L2395.

So I visited https://support.brother.com/g/b/downloadlist.aspx?c=us_ot&lang=en&prod=hll2395dw_us_as&os=127 and downloaded the hll2395dwpdrv-4.0.0-1.i386.rpm printer driver package. Then ran rpm2tgz against it and unpacked the tarball. That contains brother-HLL2395DW-cups-en.ppd, which I pointed cups to, and that seemed to install okay, with Connection: lpd://BRW9C305B7FCC10/BINARY_P1

But trying to print a test page from acroread just immediately showed a "State: stopped" on the cups page for the L2395. Then I noticed an error on the overall cups Printers page... "File "/usr/lib64/cups/filter/brother_lpdwrapper_HLL2395DW" not available: No such file or directory"

And, indeed, that file doesn't exist, although lines 25 and 26 of the .ppd read,

*cupsFilter:    "application/vnd.cups-postscript 0 brother_lpdwrapper_HLL2395DW"
*cupsFilter:    "application/vnd.cups-pdf 0 brother_lpdwrapper_HLL2395DW
I couldn't google it explicitly, and the only relevant-looking file in the Brother rpm is a 25K file just named lpdwrapper, which is an executable perl script. But it doesn't seem to do much of anything when run from the command line.

And I'm not even sure this is the problem. Has anybody actually installed an HL-L2395 on Slackware 14.2? Or have an educated guess about it? What's the correct procedure; what am I doing wrong? Thanks.

1 Answer 1

1

I tried copying that Perl script to /usr/lib64/cups/filter/brother_lpdwrapper_HLL2395DW to no avail. Then I changed the Connection string in cups to point to lpd://IPADDressOfPrinter/BINARY_P1 and used the built in cups driver for the Brother HL-L2300D and it worked.

2
  • That doesn't address the question.
    – RalfFriedl
    Commented Jun 27, 2019 at 16:52
  • Thanks, Morgan and @RalfFriedl Actually, I finally got it working "effortlessly". Went back to that Brother hll2395dw page (long link in question), and just downloaded the "Driver Install Tool", rather than the "Linux Printer Driver" rpm package. Then I made sure the printer (and my wireless access point) were all turned on and ready-to-go. Then ran that downloaded install tool, and it found the printer and installed everything. And by "everything", that includes setting up cups. And it also includes the scanner, whereby xsane recognized it immediately. So that "Install Tool" is the way to go Commented Jun 29, 2019 at 5:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .