I'm trying to install Linux Mint 13 with Cinnamon via the 64 bit DVD image from within Windows. I've tried both installing it to C: which is my Windows system disk, but also to D: which is another physical disk entirely. The same thing happens on both disks.

The Windows part of the installation completes and it tells me to reboot. When I reboot, it tries rebooting into Linux Mint to start the installation, but I only get a prompt saying grub >. If I try the boot command, it says no kernel is loaded.

I've tried looking at the boot record in EasyBCD, and it looks like this:

Entry #1
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Linux Mint
BCD ID: {62256248-e57d-11e1-9eca-d50aae34d088}
Drive: C:\
Bootloader Path: \linuxmint\winboot\wubildr.mbr

Booting Windows 7 works fine obviously, but I'm not sure why Linux Mint fails. The Bootloader Path for the Linux Mint installation checks out.

Any ideas why this is happening, and/or what I can do to troubleshoot it? I really want to install this via Wubi, and not have to mess around with partitions.

1 Answer 1


I had a quick look around and it appears that there is a bug in GRUB2 that causes it to have problems booting from NTFS partitions (source):

It seems the newer kernels (2.6.31-19 and up) and Grub2 had a strange incompatibility when trying to boot from NTFS. In this write-up, they mention that the cause of the problem is:

To be able to boot Wubi, Grub2 has to access the ntfs partition which is hosting Wubi. There is a bug in Grub 2, which prevents Grub2 to read any files on an ntfs partition beyond the first 4GB. If any of the boot files is outside of the 4GB limit, booting will fail. Depending on which boot file is outside the limit, the symptoms can be quite different. Since any kernel or Grub update relocates some of the boot files, you might be hit by this bug at any time.

So, how do we fix this? It’s actually very easy. All you need to do is download a new Wubildr file which corrects the problem from here. (You can safely do this from within Windows if you cannot boot into Linux). Then just copy that file to your Windows c:\ drive, overwriting the faulty wubildr file that was there.

I have not tried it myself as I do not use wubi but it seems to work. Good luck.

This may also be helpful.

  • It now says "GRUB 1.99" on startup but I still go straight to the grub prompt. I replaced both the wubildr in the root of the C drive, and in the subfolder of the linuxmint folder.
    – pzkpfw
    Commented Oct 7, 2012 at 8:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .