1

So I don’t understand because this always worked for me but after a new Arch Linux install I’m always prompted the GDM login screen.

I enabled autologin through gnome-control-center (“Connexion automatique” toggle)

which I believe updated /etc/gdm/custom.conf

# GDM configuration storage

[daemon]
# Uncomment the line below to force the login screen to use Xorg
#WaylandEnable=false

AutomaticLoginEnable=True
AutomaticLogin=mathieu

[security]

[xdmcp]

[chooser]

[debug]
# Uncomment the line below to turn on debugging
#Enable=true

But this configuration still gets me the login screen on boot. Did I miss something? I’m using GDM 3.30.2

Here is the content of /var/lib/AccountsService/users/mathieu

[User]
Language=
XSession=
Icon=/home/mathieu/.face
SystemAccount=false
0

Okay so it seems the root cause of the issue was this log from gnome-shell:

Failed to create backend: Could not find a primary drm kms device

I don't know why, but enabling KMS during the initramfs stage solved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.