0

The usual answer to this is that I am missing leveldb from my system, however the python3-leveldb libleveldb-dev packages includede in Debian 9 are for python3.5 but I am using python3.7

I compiled python 3.7 following this guide (with pip support) https://solarianprogrammer.com/2017/06/30/building-python-ubuntu-wsl-debian/ and when I try to install the plyvel package as such: pip3.7 install plyvel I get the error below, emphasis is on leveldb/db.h missing gcc -pthread -Wno-unused-result -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -fPIC -I/usr/local/include/python3.7m -c plyvel/_plyvel.cpp -o build/temp.linux-armv7l-3.7/plyvel/_plyvel.o -Wall -g plyvel/_plyvel.cpp:589:24: fatal error: leveldb/db.h: No such file or directory #include "leveldb/db.h"

I have already installed leveldb using pip3.7, when checking if it is installed I get back: dRequirement already satisfied: leveldb in /usr/local/lib/python3.7/site-packages (0.194)

New contributor
argabri is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

argabri is a new contributor. Be nice, and check out our Code of Conduct.

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.