0

I have VirtualBox with two VMs. One is a fully installed Debian VM, which is working fine with guest editions. The other is a new VM I created to install CentOS. The problem is, when I launch the new VM I can't use the mouse on the install screens of CentOS. It gives the error on VirtualBox of "The virtual machine reports that the guest OS does not support mouse pointer integration in the current video mode". Everyone is saying on Google that you need guest editions on the host. I can confirm I already have this installed that, because it's working with my Debian machine, and my package manager on my host machine shows it's installed (as shown below):

$  pacman -Q virtualbox-guest-iso 
virtualbox-guest-iso 6.0.4-1

I also tried all of the different video modes (VMSVGA, VBoxVGA, VBoxSVGA) with no success. What's strange is that I seem to be able to click/move my physical mouse around within the VM and select things, I just don't have a cursor. So how can I solve this issue? I need my mouse working on the CentOS installation screens, that is all I want.

EDIT: I have tried installing a number of different ISO's on this new VM, inclusive of Debian, RedHat, Fedora, and CentOS. I only seem to have this issue specifically when trying to install CentOS and RedHat.

1

Same happened to me. Eventually I found a solution on the internet that worked for me: In the machine setting on the System menu set the pointing device to USB tablet instead of the default PS/2 Mouse.

Good luck,

Dov

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.