0
  • Everything was working fine. I could connect into the system with PuTTY, and everything would display correctly.
  • I changed the language from English to Spanish using some GUI tool.
  • I changed the language back to English again (i.e., everything should now be back to how it was).
  • Various terminal programs no longer use the Unicode box-drawing characters any more.
    • lsblk now uses the verticle-pipe and backtick characters.
    • htop does likewise.
    • tmux uses rows of x characters (also q and a few others).
    • Problem appears both with and without tmux running.
  • Output from locale looks the same as before.
  • PuTTY has apparently set TERM=xterm, which has what it was before.

I'm really not sure what other settings would affect terminal rendering... but this is really driving me nuts!

2
  • Crawling through lsblk using GDB, it appears it uses libsmartcols to do the table drawing. Feb 18, 2019 at 17:26
  • It seems changing LC_CTYPE=en_GB to en_GB.utf8 fixes tmux, but not lsblk. Feb 22, 2019 at 13:19

1 Answer 1

0

Well, I thought the locale was still set the same... but it wasn't.

It turns out previously the locale was en_GB.utf8, whereas now it's just en_GB.

Setting this to the correct value outside of tmux seems to make everything behave correctly again.

A quirk is that for this to take effect inside tmux, it appears you have to exit all sessions, set the environment variable, and then start tmux again. Presumably the server itself is caching the value or something...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.