12

What I have

  1. Host: Windows 10 Version 1803
  2. Guest: 4.19.20-1-MANJARO
  3. VirtualBox Version 6.0.4r128413

What I have tried:

  1. using the VirtualBox geustaddition iso

    1.1. from toolbar Devices > Insert guestaddition image ...

    1.2. cd /run/media/foobar/VBox_GAs-6.0.4

    1.3. sudo sh autorun.sh or simply by sudo sh VBoxLinuxAdditions.run leading to the error:

This system is currently not set up to build kernel modules. Please install the Linux kernel "header" files matching the current kernel for adding new hardware support to the system. VirtualBox Guest Additions: modprobe vboxsf failed

1.4. So I tried solving the problem by installing the Linux kernel header files as mentioned here:

1.4.1 find the Linux kernel by mhwd-kernel -li which in my case is linux419

1.4.2. Then sudo pacman -S linux419-kernel

1.4.3. then following the step one in original post and reboot. This solves the resolution problem but every time I reboot I have to wait for 5-6 minutes showing the message:

A stop job is running for vboxadd.service …

enter image description here

1.4.4. Tried the sudo systemctl stop vboxadd and sudo systemctl disable vboxadd from here but then it reverts the resolution back.

1.4.5. tried uninstalling the guest additions by sudo sh VBoxLinuxAdditions.run uninstall and then following step 2 whish was also not successful!

  1. using the Manjaro repository as suggested on their wiki:

    2.1. sudo pacman -Syu virtualbox-guest-utils leading to

There are 11 providers available for VIRTUALBOX-HOST-MODULES:

:: Repository extra

  1. linux316-virtualbox-guest-modules

:: Repository community

linux-rt-lts-manjaro-virtualbox-guest-modules

2.2. from here running mhwd-kernel -li indicates that should go for linux419, or use sudo pacman -S linux419-virtualbox-guest-modules instead. but then I get the error:

error failed to commit transaction (conflicting files)

virtualbox guest utils exists in filesystem vboxclient

2.3. as suggested here I tried sudo pacman -S --force and finished the installation and rebooted. But nothing changes except that I get this notification:

enter image description here

10

To get Auto-Resize Guest Display working you have to use 'VBoxSVGA'

  1. Stop VM if installed and running
  2. Choose in VM Setting: Display > Screen > Graphics Controller > 'VBoxSVGA'
  3. Save
  4. Start VM with Manjaro - Screen goes black.
  5. hit CTRL+ALT+F2 to enter tty2
  6. logon
  7. sudo mhwd -r pci video-vmware
  8. reboot

Resizing works like a charm.

Tested on Linux, Mac OS and Windows 10

(In older versions of Virtual Box, the controller was VBoxVGA, but this is deprecated since version 6.0 and no longer available in 6.1.)

  • 2
    This should be the chosen answer for the latest version, worked perfectly. – misantroop Sep 3 '19 at 6:00
  • This really saved my day. I tried a lot of answers, only this one works. – CodyChan Oct 9 '19 at 9:04
  • This answer works in the new version. – Caio Belfort Oct 15 '19 at 19:17
8

I recently faced the same issue, and after some research I came up with the solution that doesn't require to use VBoxVGA adapter and reinstall Manjaro. The TL;DR version is, you needed to install linux419-headers, not linux419-kernel.

System specs

Host: Windows 10 1809 Pro 64 bit
Guest: Manjaro KDE 18.0.4 64 bit with 4.19.34-1-MANJARO kernel
Virtualization: VirtualBox 6.0.6 r130049 (Qt5.6.2)

Steps

  1. Do full system update:
    sudo pacman -Syyu

  2. Install gcc, make and Linux kernel "header" files for the current kernel version (which can be found via uname -r command, e.g. linux419-headers – I tried to provide a uniform command using sed and grep functionality):
    sudo pacman -S gcc make linux$(uname -r|sed 's/\W//g'|cut -c1-2)-headers

  3. Reboot:
    sudo reboot

  4. Mount the ISO via Devices → Guest Additions CD Image… and open the terminal there.

  5. Run
    sudo sh VBoxLinuxAdditions.run

  6. Reboot:
    sudo reboot

At this point Manjaro should work fine with the new VMSVGA controller adjusting screen resolution on the fly (make sure you allocated enough video memory (128 Mb) and enabled acceleration in VM settings beforehand), seamlessly share buffer and allow drag-and-drop.

Update

Recent kernel update from 4.19.34-1-MANJARO to 5.0.9-2-MANJARO didn't affect functionality of Guest Additions and no additional tweaking was required:

Screenshot of an arbitrary resolution of updated kernel

  • 2
    For me the 'uniform command' didn't work to install the headers, I just got error: target not found: linux521-headers, however running sudo pacman -S linux52-headers did work and installed linux52-headers-5.2.11-1. – nakamin Sep 22 '19 at 13:49
  • @nakamin Thank you, I corrected the command (crop to two instead of three numbers in kernel version). Probably package naming changed with the release of kernel version 5. – andselisk Nov 4 '19 at 20:04
3

The last post in the forum which meepmeep linked in his answer did the trick for me:

  1. installing the correct driver and uninstalling the incorrect one

    mhwd -i pci video-virtualbox
    mhwd -r pci video-vmware
    
  2. shutdown and change the VM graphics controller to VboxVGA

  • In addition to this, I need to install guest addition utils sudo pacman -S virtualbox-guest-utils. – MichaelZ Dec 2 '19 at 16:16
1

One thing you can try is making sure your VB session is NOT running. Got to its settings and click on Display > Screen > and under 'Graphics Controller' pull down the menu and select 'VBoxVGA'. Save and exit, and restart your VB session.

  • 2
    I tried this and now the screen is all black! – Foad Feb 11 '19 at 16:23
1

I've been having the same problem, and have failed to resolve this in similar steps. The issue seems to be with the graphics controller option introduced in Virtualbox 6.0.

I found that if you create a fresh installation using the 'VBoxVGA' controller from the very beginning, then everything works correctly, but if you install using the default 'VMSVGA' controller then it doesn't seem to be possible to revert/fix any of the issues through any obvious means.

See more info here also with a possible suggestion on fixing an existing installation (though only setting the option at installation worked for me): https://forum.manjaro.org/t/cant-auto-resize-guest-display-in-virtualbox/78030/9

Not the answer you're looking for? Browse other questions tagged or ask your own question.