0

I want to run an application that need python3 and pyqt5 in Slitaz 5. I am not pro in linux but managed to compile and install python3. now when I try to run application it tell me that need pyqt5. so I:

sudo pip3 install PyQy5

but I get

Could not find a version that satisifies the requirement PyQt5 (from versions: )
No matching distribution found for PyQt5

how can I fix it? should I compile qt5 from source code? then how?

  • Which version of Python 3 did you install? Is it at least 3.5? – Nasir Riley Feb 11 at 12:28
  • @NasirRiley python 3.7 – m3hdi Feb 11 at 16:07
0

https://www.riverbankcomputing.com/software/pyqt/download5

The above website provides the source code for compilation and installation.

On the website, it says "Before you can build PyQt5 you must have already built and installed SIP"

You might want to try first

pip3 install PyQt5-sip

then try

pip3 install PyQt5

If this fails, building from the source code is the best bet, I guess.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.