8

I just upgraded to Mint 13 - KDE x64

I am unable to switch to ttys by using the CtrlAltF1 .. F6 keys. The gettys are running and I can switch to the terminals with the sudo chvt 1 command.

I have browsed to quite a few topics and have not reached a solution that works. I even reinstalled grub with terminal=console. Once I make a selection at the boot menu, I do not see any boot messages - just KDE starting after a few seconds.

How do I fix this?

  • 3
    That is determined by your X server config (/etc/X11/xorg.conf). There is an option Option "DontVTSwitch". Do you have that enabled? – Keith Oct 5 '12 at 0:06
  • /etc/X11/xorg.conf does not seem to exist. Is there any other file where I could look for this option? I tried looking at other files in the directory and could not find it. – Lord Loh. Oct 5 '12 at 0:41
  • 1
    What does locate xorg.conf show you? – Keith Oct 5 '12 at 0:47
  • 1
    Someone else with this problem discovered that their keys had been remapped. A possibility for you? – ire_and_curses Oct 5 '12 at 3:45
  • 1
    Thanks to inspiration from the comments here, I managed to fix it. (mattcutts.com/blog/virtual-terminal-not-working) was a great help. I entered the kcmshell4 kcm_keyboard > advanced tab > Miscellaneus compatibility option > and unchecked the special keys (ctrl + alt + <key>) handled in a server. Things went in place! I would still like to know where this sets the options in configuration files... – Lord Loh. Oct 5 '12 at 19:49
4

Thanks to inspiration from the comments here, I managed to fix it. This was a great help. I entered the kcmshell4 kcm_keyboard > advanced tab > Miscellaneus compatibility option > and unchecked the special keys (ctrl + alt + key) handled in a server. Things went in place! I would still like to know where this sets the options in configuration files...

1

I encountered this problem in Gnome Desktop 2.28.2 and Red Hat Enterprise Linux Workstation 6.9. My initial steps differed from @LordLoh.'s steps, but the final steps were identical:

  1. Navigated the Red Hat menu: System → Preferences → Keyboard
  2. Visited the "Layouts" tab.
  3. Clicked the "Layout Options..." button.
  4. Expanded the "Miscellaneous compatibility options" section.
  5. Deselected/unchecked the "Special keys (Ctrl+Alt+<key>) handled in a server" option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.