0

Recently I've installed Ubuntu 18.04 on my pc alongside Windows 10. I added nouveau.modeset to grub boot script to be able to log in (there is an issue on Dell XPS 15, which prevents ubuntu from logging in without this option). After that, I wasn't able to change the screen brightness with the usual shortcut shift+f11/shift+f12. I added apci_backlight=vendor to the aforementioned grub boot script (/etc/default/grub). After that, I was able to change the brightness simply by f11/f12. Also, the sound could be changed with f3/f4 (I was using shift+f3/shift+f4 before). The problem is that I can't, for instance, reload the page in the browser with f5, because the keymap has been changed.

So, the question is: how to change the keymap back again?

Note: The same issue in my Windows installation, so this seems to be a system problem. I already tried to update BIOS firmware to restore the settings, but this didn't work out.

  • 1
    Use the fn key + f5. It does not seem a Unix problem. – Rui F Ribeiro Feb 9 at 13:23
  • I also can't use other shortcuts in, for instance, IDEA's. Should I post this question somewhere else? – Тимофей Чудаков Feb 9 at 13:27
  • Just to be clear, are you certain you didn't just accidentally press the function lock combination (Fn+Esc) ? – undercat Feb 9 at 14:03
  • In fact, I did. I didn't know about fn-reversing, thanks. – Тимофей Чудаков Feb 9 at 17:17
0

This was already answered here, and just googling by "Function Keys Dell XPS" will get you to this AskUbuntu question: How to invert fn keys on Dell Laptop?

Pressing Fn+Esc changes the Fn lock so, your function keys will not behave as multimedia/backlight control keys as default, and will be reverted to function keys.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.