2

After installing TrueOS to unallocated disk space, my computer didn't boot properly any more. With choosing a boot image, my screen froze. So I ran the rescue mode of a debian install medium and reinstalled the MBR (Master Boot Record). Now, GRUB acts as if debian was the only system on the drive.

I tried updating GRUB from GNU/Linux, which gave me the following:

$ sudo LC_ALL=C update-grub Generating grub configuration file ... Found background image: .background_cache.png Found linux image: /boot/vmlinuz-4.19.0-2-amd64 Found initrd image: /boot/initrd.img-4.19.0-2-amd64 Found linux image: /boot/vmlinuz-4.19.0-1-amd64 Found initrd image: /boot/initrd.img-4.19.0-1-amd64 Found memdisk: /memdisk Imagepath /boot/images not found done

Now I'm at the point where I take any *BSD which has a GUI by default. How do I have to modify the file telling GRUB which OSes there are available? Which file is it (in)?

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.