0

I'm running a ubuntu server installation with a tty console, and sshd terminal logins. Both ssh keys and passwords work for authenticating over sshd. Lately, on the console, when I try to log in in text mode, I get a curious behavior: I enter my login name. It prompts for the password. However, it very quickly prints a newline, and whatever part of the password I hadn't typed already is echoed in cleartext to the console. Then, it prompts for login:, but quickly times out and prompts for login: again ... 5 times, until it goes back to clear the screen, and re-issue the agetty process. At that point it's "stable" and waits for a username again, but entering a username and pressing enter re-starts the "timeout and newline" behavior.

The systemd log for getty@tty1 says the following:

-- Unit getty@tty1.service has finished starting up.
--
-- The start-up result is RESULT.
Feb 08 12:12:47 xps15 login[1610]: pam_unix(login:auth): conversation failed
Feb 08 12:12:47 xps15 login[1610]: pam_unix(login:auth): auth could not identify password for [jwatte]
Feb 08 12:12:50 xps15 login[1610]: FAILED LOGIN (1) on '/dev/tty1' FOR 'jwatte', Authentication failure
Feb 08 12:12:51 xps15 login[1610]: pam_securetty(login:auth): cannot determine username
Feb 08 12:12:54 xps15 login[1610]: FAILED LOGIN (2) on '/dev/tty1' FOR 'UNKNOWN', Error in service module
Feb 08 12:12:55 xps15 login[1610]: pam_securetty(login:auth): cannot determine username
Feb 08 12:12:58 xps15 login[1610]: FAILED LOGIN (3) on '/dev/tty1' FOR 'UNKNOWN', Error in service module
Feb 08 12:12:59 xps15 login[1610]: pam_securetty(login:auth): cannot determine username
Feb 08 12:13:03 xps15 login[1610]: FAILED LOGIN (4) on '/dev/tty1' FOR 'UNKNOWN', Error in service module
Feb 08 12:13:03 xps15 login[1610]: pam_securetty(login:auth): cannot determine username
Feb 08 12:13:06 xps15 login[1610]: FAILED LOGIN (5) on '/dev/tty1' FOR 'UNKNOWN', Error in service module
Feb 08 12:13:06 xps15 login[1610]: TOO MANY LOGIN TRIES (5) on '/dev/tty1' FOR 'UNKNOWN'
Feb 08 12:13:06 xps15 login[1610]: pam_mail(login:session): cannot determine username
Feb 08 12:13:06 xps15 login[1610]: pam_unix(login:session): close_session - error recovering username
Feb 08 12:13:06 xps15 systemd[1]: getty@tty1.service: Service has no hold-off time, scheduling restart.
Feb 08 12:13:06 xps15 systemd[1]: getty@tty1.service: Scheduled restart job, restart counter is at 1.
-- Subject: Automatic restarting of a unit has been scheduled
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
--
-- Automatic restarting of the unit getty@tty1.service has been scheduled, as the result for
-- the configured Restart= setting for the unit.

I imagine the problem is the first two lines:

pam_unix(login:auth): conversation failed
pam_unix(login:auth): auth could not identify password for [jwatte]

Why would this happen, and how can I best debug it?

-1

This turns out to be caused by: https://askubuntu.com/questions/1113704/tty-doesnt-wait-for-password

I don't have mojo points enough to mark this question to redirect there, but thanks to @PerlDuck for providing the answer!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.