I have Linux Mint 19 Tara and today I installed new updates of packages which you can see below in the picture. After that during sudo usage sudo shows * instead of nothing. Sudo works but this is strange, after I hit enter, stars will disappear.

$ sudo echo
[sudo] password for matej: *********

Another strange thing is with console, at first open I can write my username but password gets confirmed without my interference. So I can't login to console.

updated packages

  • 2
    Take a look at your /etc/sudoers file; the update likely added a pwfeedback to your Defaults section.
    – Jeff Schaller
    Feb 7 '19 at 18:46
  • 1
    (Reference: askubuntu.com/a/387764/619216)
    – Jeff Schaller
    Feb 7 '19 at 18:47
  • @JeffSchaller You are right! There is file /etc/sudoers.d/0pwfeedback and with ls I can see today's date. What should I do with this file? Remove it or modify it?
    – Matej
    Feb 7 '19 at 19:00
  • @JeffSchaller All right, I delted this file but still I can't log in to the console. Any idea?
    – Matej
    Feb 7 '19 at 20:03
  • 1
    Feel free to self-answer with the solutions!
    – Jeff Schaller
    Feb 7 '19 at 20:34

After @JeffSchaller directed me to this password feedback I found that in /etc/sudoers.d is new file named 0pwfeedback with content Defaults pwfeedback. After removing this file, problem with stars in sudo was solved.

Second problem with login to console is known: ubuntu bugs but I am still trying figure out how to solve it.

Edit 6.3.2019:

It looks like kernel 4.15.0-46 solved problem with console login. I can now normally login into console and password input is not automatically entered.

$ uname -r

The change in sudo behavior is actually mentioned in the release notes of Linux Mint 19.1 Tessa:

To prevent you from typing your password into the wrong window (and sending it online by mistake), sudo now shows asterisks when you type your password.

What is not mentioned, however, and I'm not sure whether this was intended, is that it was automatically introduced into 19.0 with a normal update.

If you want to revert the change, see this question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.