0

I am trying to install realvnc server on my CentOS 7 VM. I've downloaded the rpm package from the official website.

I am using ESXI and nothing is or should be connected to the internet.

When trying sudo yum install VNC-Server-6.4.0-Linux-x64.rpm it fails because it tries to connect to the internet to download packages there.

here the output:

[frodo@localhost ~]$ sudo yum install Desktop/VNC-Server-6.4.0-Linux-x64.rpm 
[sudo] password for frodo: 
Loaded plugins: fastestmirror, langpacks
Examining Desktop/VNC-Server-6.4.0-Linux-x64.rpm: realvnc-vnc-server-6.4.0.39899-1.x86_64
Marking Desktop/VNC-Server-6.4.0-Linux-x64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package realvnc-vnc-server.x86_64 0:6.4.0.39899-1 will be installed
--> Processing Dependency: xterm for package: realvnc-vnc-server-6.4.0.39899-1.x86_64
Loading mirror speeds from cached hostfile
Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=7&arch=x86_64&repo=os&infra=stock error was
14: curl#6 - "Could not resolve host: mirrorlist.centos.org; Unknown error"


 One of the configured repositories failed (Unknown),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Run the command with the repository temporarily disabled
            yum --disablerepo=<repoid> ...

     4. Disable the repository permanently, so yum won't use it by default. Yum
        will then just ignore the repository until you permanently enable it
        again or use --enablerepo for temporary usage:

            yum-config-manager --disable <repoid>
        or
            subscription-manager repos --disable=<repoid>

     5. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot find a valid baseurl for repo: base/7/x86_64
  • The RPM VNC-Server-6.4.0-Linux-x64.rpm looks to have a dependency on the package xterm, you will need to download all dependencies of your package, and all dependencies of those packages to be able to install them properly. Since this machine is offline, it would probably be easier to mount the DVD image that contains all of the packages and configure it as your base repository so you do not run into this problem. You probably also want to disable all of the yum repositories that require connecting to the internet. – GracefulRestart Feb 7 at 19:02
  • Thanks for the help, there are over 20 dependencies. To save time I cheated a bit and set it up on my machine with VMWare and put it on NAT. After installing over the internet I pushed the VM to the ESXI Server. – Yannis Feb 11 at 15:36
0

if the goal is just to install this rpm and pray it doesn't need any dependencies; then you can just:

rpm -ivh VNC-Server-6.4.0-Linux-x64.rpm

The goal of using yum over rpm is that yum knows about repositories where to find packages; so if VNC-Server needs another package, yum could immediately download it from one of its repositories and install it. rpm won't do that for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.