0

In a Raspberry Pi3. I have valid PPP configuration in my Raspbian Stretch that I'm able to launch manually from terminal. But it doesn't work if try to do it on boot.

This is my setup:

  • File /etc/ppp/options with valid data
  • File /etc/ppp/peers/my_provider with valid data
  • File /etc/network/interfaces with this section:
auto ppp0
iface ppp0 inet ppp
provider my_provider

If I launch pppd or pon manually, both mechanisms work as expected:

sudo pppd file /etc/ppp/peers/my_provider

Or:

sudo pon my_provider

But when the system boots pppdfails. Looking at syslog, I see this error message:

In file /etc/ppp/peers/my_provider: unrecognized option '/dev/modemttyUSB2'

But this files exists when I access to my Raspberry Pi:

$ ll /dev/modemttyUSB2
lrwxrwxrwx 1 root root 7 Feb  6 15:23 /dev/modemttyUSB2 -> ttyUSB2

My guess is that this file /dev/modemttyUSB2, that actually is a symlink, is not yet ready at the moment that network configuration is executed on boot.

My modem is a ZTE MF833V and I installed the software that comes with it. So probably this software is creating this symlink, but I don't know when or how.

How can I make my modem connection start on boot? Preferably I want use configuration in /etc/network/interfaces file, instead of a cron/init script.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.