3

The magnet link is correctly set with xdg-mime to open in transmission, and also in .local/share/applications/mimeapps.list.

If transmission is NOT running, everything works as expected (click a magnet link or torrent file, and it opens).

If transmission is running, clicking on a magnet link in chrome will open a second transmission window.

This does not occur neither in firefox nor with the command xdg-open "magnet-link". The problems seems to be only in chrome.

Tech specs:

Debian buster with 4.19.0-2-amd64, fully upgraded.
transmission-gtk 2.94 (d8e60ee44f)
google chrome Version 72.0.3626.81 (Official Build) (64-bit)
xdg-open 1.1.3
awesome WM v4.3

edit: Checking chrome's log, I can see this related line

[21407:21407:0207/152959.142127:VERBOSE1:navigator_impl.cc(111)] Failed Provisional Load: magnet:?xt=urn:btih:<magnet_url_with_trackers-hidden_for_privacy>, error_code: -3, error_description: The webpage at <strong jscontent="failedUrl"></strong> might be temporarily down or it may have moved permanently to a new web address., showing_repost_interstitial: 0, frame_id: 4

1 Answer 1

0

Quite late but for anyone arriving here with the same issue: I discovered this is happenning due to chrome/chromium changing environment variables.

In my case chromuim set DBUS_SESSION_BUS_ADDRESS=disabled:

I fixed it by adding unset DBUS_SESSION_BUS_ADDRESS right after the #!/bin/sh in the start of /usr/bin/xdg-open

You can use this command:

sudo sed -i 's:#!/bin/sh:#!/bin/sh\nunset DBUS_SESSION_BUS_ADDRESS:' /usr/bin/xdg-open

Note you'll have to run it again every time package xdg-util being updated.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .