1

I was attempting to install virt-manager on my computer. I didn't pay attention and i went ahead with the install. Apparently one of my repositories was down at the time- So almost all of my core packages got removed or marked as not needed/uninstalled. The first things i notice is that I cannot use the internet and that i am using XFCE instead of Gnome. I login, resolve the network issue, and attempt to install the gnome desktop environment with sudo apt-get -s -o Debug::pkgProblemResolver=yes install gnome, the following is the output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Starting pkgProblemResolver with broken count: 9
Starting 2 pkgProblemResolver with broken count: 9
Investigating (0) gnome:amd64 < none -> 1:3.22+3 @un puN Ib >
Broken gnome:amd64 Depends on libproxy1-plugin-networkmanager:amd64 < none | 0.4.14-2 @un uH >
  Considering libproxy1-plugin-networkmanager:amd64 2 as a solution to gnome:amd64 9999
    Reinst Failed early because of libproxy1v5:amd64
Broken gnome:amd64 Depends on libreoffice-evolution:amd64 < none | 1:5.2.7-1+deb9u5 @un uH >
  Considering libreoffice-evolution:amd64 1 as a solution to gnome:amd64 9999
    Reinst Failed early because of libreoffice-core:amd64
  Considering libreoffice-evolution:amd64 1 as a solution to gnome:amd64 9999
Investigating (0) libevolution:amd64 < none -> 3.22.6-1+deb9u1 @un uN Ib >
Broken libevolution:amd64 Depends on libgail-3-0:amd64 < none | 3.22.11-1 @un uH > (>= 3.0.0)
  Considering libgail-3-0:amd64 0 as a solution to libevolution:amd64 9
  Holding Back libevolution:amd64 rather than change libgail-3-0:amd64
Investigating (0) gnome-control-center:amd64 < none -> 1:3.22.2-3 @un uN Ib >
Broken gnome-control-center:amd64 Depends on libgoa-backend-1.0-1:amd64 < none | 3.22.5-1 @un uH > (>= 3.10.0)
  Considering libgoa-backend-1.0-1:amd64 0 as a solution to gnome-control-center:amd64 9
  Holding Back gnome-control-center:amd64 rather than change libgoa-backend-1.0-1:amd64
Investigating (0) evolution:amd64 < none -> 3.22.6-1+deb9u1 @un uN Ib >
Broken evolution:amd64 Depends on libevolution:amd64 < none | 3.22.6-1+deb9u1 @un uH > (>= 3.22.6)
  Considering libevolution:amd64 9 as a solution to evolution:amd64 4
  Holding Back evolution:amd64 rather than change libevolution:amd64
Investigating (0) p11-kit:amd64 < none -> 0.23.3-2 @un uN Ib >
Broken p11-kit:amd64 Depends on p11-kit-modules:amd64 < none | 0.23.3-2 @un uH > (>= 0.23.3-2)
  Considering p11-kit-modules:amd64 0 as a solution to p11-kit:amd64 3
  Holding Back p11-kit:amd64 rather than change p11-kit-modules:amd64
Investigating (0) nautilus:amd64 < none -> 3.22.3-1+deb9u1 @rc uN Ib >
Broken nautilus:amd64 Depends on libgail-3-0:amd64 < none | 3.22.11-1 @un uH > (>= 3.0.0)
  Considering libgail-3-0:amd64 0 as a solution to nautilus:amd64 3
  Holding Back nautilus:amd64 rather than change libgail-3-0:amd64
Investigating (0) evolution-plugins:amd64 < none -> 3.22.6-1+deb9u1 @un uN Ib >
Broken evolution-plugins:amd64 Depends on libevolution:amd64 < none | 3.22.6-1+deb9u1 @un uH > (>= 3.22.6)
  Considering libevolution:amd64 9 as a solution to evolution-plugins:amd64 3
  Holding Back evolution-plugins:amd64 rather than change libevolution:amd64
Investigating (0) gnome-sushi:amd64 < none -> 3.21.91-2 @un uN Ib >
Broken gnome-sushi:amd64 Depends on nautilus:amd64 < none | 3.22.3-1+deb9u1 @rc uH > (>= 3.2)
  Considering nautilus:amd64 3 as a solution to gnome-sushi:amd64 2
  Holding Back gnome-sushi:amd64 rather than change nautilus:amd64
Investigating (0) gnome-shell-extensions:amd64 < none -> 3.22.2-1 @un uN Ib >
Broken gnome-shell-extensions:amd64 Depends on gvfs:amd64 < none | 1.30.4-1 @un uH > (>= 1.16.0)
  Considering gvfs:amd64 9 as a solution to gnome-shell-extensions:amd64 0
  Holding Back gnome-shell-extensions:amd64 rather than change gvfs:amd64
Investigating (0) gnome-core:amd64 < none -> 1:3.22+3 @un uN Ib >
Broken gnome-core:amd64 Depends on gnome-control-center:amd64 < none | 1:3.22.2-3 @un uH > (>= 1:3.22)
  Considering gnome-control-center:amd64 9 as a solution to gnome-core:amd64 0
  Holding Back gnome-core:amd64 rather than change gnome-control-center:amd64
Investigating (0) gvfs-fuse:amd64 < none -> 1.30.4-1 @un uN Ib >
Broken gvfs-fuse:amd64 Depends on gvfs:amd64 < none | 1.30.4-1 @un uH > (= 1.30.4-1)
  Considering gvfs:amd64 9 as a solution to gvfs-fuse:amd64 0
  Holding Back gvfs-fuse:amd64 rather than change gvfs:amd64
Investigating (0) gnome-orca:amd64 < none -> 3.22.2-3 @rc uN Ib >
Broken gnome-orca:amd64 Depends on python3-brlapi:amd64 < none | 5.4-7+deb9u1 @un uH > (>= 0.5.1)
  Considering python3-brlapi:amd64 0 as a solution to gnome-orca:amd64 0
  Holding Back gnome-orca:amd64 rather than change python3-brlapi:amd64
Investigating (1) gnome:amd64 < none -> 1:3.22+3 @un puN Ib >
Broken gnome:amd64 Depends on gnome-core:amd64 < none | 1:3.22+3 @un uH > (= 1:3.22+3)
  Considering gnome-core:amd64 0 as a solution to gnome:amd64 9999
    Reinst Failed early because of libgoa-1.0-common:amd64
    Reinst Failed because of libgoa-backend-1.0-1:amd64
    Reinst Failed because of gnome-control-center:amd64
Broken gnome:amd64 Depends on libproxy1-plugin-networkmanager:amd64 < none | 0.4.14-2 @un uH >
  Considering libproxy1-plugin-networkmanager:amd64 2 as a solution to gnome:amd64 9999
Broken gnome:amd64 Depends on evolution:amd64 < none | 3.22.6-1+deb9u1 @un uH > (>= 3.22)
  Considering evolution:amd64 4 as a solution to gnome:amd64 9999
    Reinst Failed early because of libgtk-3-0:amd64
    Reinst Failed because of libgail-3-0:amd64
    Reinst Failed because of libevolution:amd64
Broken gnome:amd64 Depends on evolution-plugins:amd64 < none | 3.22.6-1+deb9u1 @un uH > (>= 3.22)
  Considering evolution-plugins:amd64 3 as a solution to gnome:amd64 9999
    Reinst Failed because of libevolution:amd64
Broken gnome:amd64 Depends on gnome-orca:amd64 < none | 3.22.2-3 @rc uH > (>= 3.22)
  Considering gnome-orca:amd64 0 as a solution to gnome:amd64 9999
    Reinst Failed early because of python3:amd64
    Reinst Failed because of python3-brlapi:amd64
  Considering gnome-orca:amd64 0 as a solution to gnome:amd64 9999
Broken gnome:amd64 Depends on libreoffice-evolution:amd64 < none | 1:5.2.7-1+deb9u5 @un uH >
  Considering libreoffice-evolution:amd64 1 as a solution to gnome:amd64 9999
  Considering libreoffice-evolution:amd64 1 as a solution to gnome:amd64 9999
Investigating (1) gnome-keyring:amd64 < none -> 3.20.0-3 @un uN Ib >
Broken gnome-keyring:amd64 Depends on p11-kit:amd64 < none | 0.23.3-2 @un uH > (>= 0.16)
  Considering p11-kit:amd64 3 as a solution to gnome-keyring:amd64 14
  Holding Back gnome-keyring:amd64 rather than change p11-kit:amd64
Investigating (1) seahorse:amd64 < none -> 3.20.0-3.1 @un uN Ib >
Broken seahorse:amd64 Depends on gnome-keyring:amd64 < none | 3.20.0-3 @un uH > (>= 3.4)
  Considering gnome-keyring:amd64 14 as a solution to seahorse:amd64 1
  Holding Back seahorse:amd64 rather than change gnome-keyring:amd64
Investigating (2) gnome:amd64 < none -> 1:3.22+3 @un puN Ib >
Broken gnome:amd64 Depends on gnome-core:amd64 < none | 1:3.22+3 @un uH > (= 1:3.22+3)
  Considering gnome-core:amd64 0 as a solution to gnome:amd64 9999
Broken gnome:amd64 Depends on libproxy1-plugin-networkmanager:amd64 < none | 0.4.14-2 @un uH >
  Considering libproxy1-plugin-networkmanager:amd64 2 as a solution to gnome:amd64 9999
Broken gnome:amd64 Depends on evolution:amd64 < none | 3.22.6-1+deb9u1 @un uH > (>= 3.22)
  Considering evolution:amd64 4 as a solution to gnome:amd64 9999
Broken gnome:amd64 Depends on evolution-plugins:amd64 < none | 3.22.6-1+deb9u1 @un uH > (>= 3.22)
  Considering evolution-plugins:amd64 3 as a solution to gnome:amd64 9999
Broken gnome:amd64 Depends on gnome-orca:amd64 < none | 3.22.2-3 @rc uH > (>= 3.22)
  Considering gnome-orca:amd64 0 as a solution to gnome:amd64 9999
  Considering gnome-orca:amd64 0 as a solution to gnome:amd64 9999
Broken gnome:amd64 Depends on seahorse:amd64 < none | 3.20.0-3.1 @un uH > (>= 3.20)
  Considering seahorse:amd64 1 as a solution to gnome:amd64 9999
    Reinst Failed early because of libp11-kit0:amd64
    Reinst Failed because of p11-kit-modules:amd64
    Reinst Failed because of p11-kit:amd64
    Reinst Failed because of gnome-keyring:amd64
Broken gnome:amd64 Depends on libreoffice-evolution:amd64 < none | 1:5.2.7-1+deb9u5 @un uH >
  Considering libreoffice-evolution:amd64 1 as a solution to gnome:amd64 9999
  Considering libreoffice-evolution:amd64 1 as a solution to gnome:amd64 9999
Investigating (2) evolution-data-server:amd64 < none -> 3.22.7-1 @un uN Ib >
Broken evolution-data-server:amd64 Depends on gnome-keyring:amd64 < none | 3.20.0-3 @un uH >
  Considering gnome-keyring:amd64 14 as a solution to evolution-data-server:amd64 15
  Holding Back evolution-data-server:amd64 rather than change gnome-keyring:amd64
Investigating (2) libfolks-eds25:amd64 < none -> 0.11.3-2 @un uN Ib >
Broken libfolks-eds25:amd64 Depends on evolution-data-server:amd64 < none | 3.22.7-1 @un uH > (>= 3.2.0)
  Considering evolution-data-server:amd64 15 as a solution to libfolks-eds25:amd64 5
  Holding Back libfolks-eds25:amd64 rather than change evolution-data-server:amd64
Investigating (3) gnome:amd64 < none -> 1:3.22+3 @un puN Ib >
Broken gnome:amd64 Depends on gnome-core:amd64 < none | 1:3.22+3 @un uH > (= 1:3.22+3)
  Considering gnome-core:amd64 0 as a solution to gnome:amd64 9999
Broken gnome:amd64 Depends on libproxy1-plugin-networkmanager:amd64 < none | 0.4.14-2 @un uH >
  Considering libproxy1-plugin-networkmanager:amd64 2 as a solution to gnome:amd64 9999
Broken gnome:amd64 Depends on evolution:amd64 < none | 3.22.6-1+deb9u1 @un uH > (>= 3.22)
  Considering evolution:amd64 4 as a solution to gnome:amd64 9999
Broken gnome:amd64 Depends on evolution-plugins:amd64 < none | 3.22.6-1+deb9u1 @un uH > (>= 3.22)
  Considering evolution-plugins:amd64 3 as a solution to gnome:amd64 9999
Broken gnome:amd64 Depends on gnome-orca:amd64 < none | 3.22.2-3 @rc uH > (>= 3.22)
  Considering gnome-orca:amd64 0 as a solution to gnome:amd64 9999
  Considering gnome-orca:amd64 0 as a solution to gnome:amd64 9999
Broken gnome:amd64 Depends on seahorse:amd64 < none | 3.20.0-3.1 @un uH > (>= 3.20)
  Considering seahorse:amd64 1 as a solution to gnome:amd64 9999
Broken gnome:amd64 Depends on libreoffice-evolution:amd64 < none | 1:5.2.7-1+deb9u5 @un uH >
  Considering libreoffice-evolution:amd64 1 as a solution to gnome:amd64 9999
  Considering libreoffice-evolution:amd64 1 as a solution to gnome:amd64 9999
Investigating (3) gnome-shell:amd64 < none -> 3.22.3-3 @un uN Ib >
Broken gnome-shell:amd64 Depends on evolution-data-server:amd64 < none | 3.22.7-1 @un uH > (>= 3.17.2)
  Considering evolution-data-server:amd64 15 as a solution to gnome-shell:amd64 42
  Holding Back gnome-shell:amd64 rather than change evolution-data-server:amd64
Investigating (3) gnome-contacts:amd64 < none -> 3.22.1-1+b2 @un uN Ib >
Broken gnome-contacts:amd64 Depends on libfolks-eds25:amd64 < none | 0.11.3-2 @un uH > (>= 0.7.3)
  Considering libfolks-eds25:amd64 5 as a solution to gnome-contacts:amd64 6
  Holding Back gnome-contacts:amd64 rather than change libfolks-eds25:amd64
Investigating (3) gdm3:amd64 < none -> 3.22.3-3+deb9u2 @rc uN Ib >
Broken gdm3:amd64 Depends on gnome-shell:amd64 < none | 3.22.3-3 @un uH > (>= 3.19.92)
  Considering gnome-shell:amd64 42 as a solution to gdm3:amd64 6
  Holding Back gdm3:amd64 rather than change gnome-shell:amd64
Investigating (3) network-manager-gnome:amd64 < none -> 1.4.4-1+deb9u1 @rc uN Ib >
Broken network-manager-gnome:amd64 Depends on policykit-1-gnome:amd64 < none | 0.105-6 @un uH >
  Considering policykit-1-gnome:amd64 1 as a solution to network-manager-gnome:amd64 5
  Holding Back network-manager-gnome:amd64 rather than change policykit-1-gnome:amd64
Broken network-manager-gnome:amd64 Depends on polkit-1-auth-agent:amd64 < none @un H >
  Considering policykit-1-gnome:i386 0 as a solution to network-manager-gnome:amd64 5
  Holding Back network-manager-gnome:amd64 rather than change polkit-1-auth-agent:amd64
  Or group keep for network-manager-gnome:amd64
Investigating (3) gnome-session:amd64 < none -> 3.22.3-1 @un uN Ib >
Broken gnome-session:amd64 Depends on gnome-shell:amd64 < none | 3.22.3-3 @un uH > (>= 3.19)
  Considering gnome-shell:amd64 42 as a solution to gnome-session:amd64 4
  Holding Back gnome-session:amd64 rather than change gnome-shell:amd64
Investigating (3) chrome-gnome-shell:amd64 < none -> 8-4 @un uN Ib >
Broken chrome-gnome-shell:amd64 Depends on gnome-shell:amd64 < none | 3.22.3-3 @un uH >
  Considering gnome-shell:amd64 42 as a solution to chrome-gnome-shell:amd64 0
  Holding Back chrome-gnome-shell:amd64 rather than change gnome-shell:amd64
Investigating (4) gnome:amd64 < none -> 1:3.22+3 @un puN Ib >
Broken gnome:amd64 Depends on gnome-core:amd64 < none | 1:3.22+3 @un uH > (= 1:3.22+3)
  Considering gnome-core:amd64 0 as a solution to gnome:amd64 9999
Broken gnome:amd64 Depends on network-manager-gnome:amd64 < none | 1.4.4-1+deb9u1 @rc uH > (>= 1.4)
  Considering network-manager-gnome:amd64 5 as a solution to gnome:amd64 9999
  Re-Instated policykit-1-gnome:amd64
  Re-Instated network-manager-gnome:amd64
Broken gnome:amd64 Depends on libproxy1-plugin-networkmanager:amd64 < none | 0.4.14-2 @un uH >
  Considering libproxy1-plugin-networkmanager:amd64 2 as a solution to gnome:amd64 9999
Broken gnome:amd64 Depends on evolution:amd64 < none | 3.22.6-1+deb9u1 @un uH > (>= 3.22)
  Considering evolution:amd64 4 as a solution to gnome:amd64 9999
Broken gnome:amd64 Depends on evolution-plugins:amd64 < none | 3.22.6-1+deb9u1 @un uH > (>= 3.22)
  Considering evolution-plugins:amd64 3 as a solution to gnome:amd64 9999
Broken gnome:amd64 Depends on gnome-orca:amd64 < none | 3.22.2-3 @rc uH > (>= 3.22)
  Considering gnome-orca:amd64 0 as a solution to gnome:amd64 9999
  Considering gnome-orca:amd64 0 as a solution to gnome:amd64 9999
Broken gnome:amd64 Depends on seahorse:amd64 < none | 3.20.0-3.1 @un uH > (>= 3.20)
  Considering seahorse:amd64 1 as a solution to gnome:amd64 9999
Broken gnome:amd64 Depends on libreoffice-evolution:amd64 < none | 1:5.2.7-1+deb9u5 @un uH >
  Considering libreoffice-evolution:amd64 1 as a solution to gnome:amd64 9999
  Considering libreoffice-evolution:amd64 1 as a solution to gnome:amd64 9999
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnome : Depends: gnome-core (= 1:3.22+3) but it is not going to be installed
         Depends: libproxy1-plugin-networkmanager but it is not going to be installed
         Depends: evolution (>= 3.22) but it is not going to be installed
         Depends: evolution-plugins (>= 3.22) but it is not going to be installed
         Depends: gnome-orca (>= 3.22) but it is not going to be installed
         Depends: seahorse (>= 3.20) but it is not going to be installed
         Depends: libreoffice-evolution but it is not going to be installed
         Recommends: brasero but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

What happened? How do i resolve this?

EDIT: The following are the contents of my /etc/apt/sources.list:

# 

# deb cdrom:[Debian GNU/Linux 9.6.0 _Stretch_ - Official amd64 NETINST 20181110-11:34]/ stretch main

# deb cdrom:[Debian GNU/Linux 9.6.0 _Stretch_ - Official amd64 NETINST 20181110-11:34]/ stretch main

deb http://mirrors.kernel.org/debian/ stretch main
deb-src http://mirrors.kernel.org/debian/ stretch main

deb http://security.debian.org/debian-security stretch/updates main

# stretch-updates, previously known as 'volatile'
deb http://mirrors.kernel.org/debian/ stretch-updates main
deb https://packages.sury.org/php/ stretch main
# deb-src https://packages.sury.org/php/ stretch main
# deb-src https://packages.sury.org/php/ stretch main
deb-src http://mirrors.kernel.org/debian/ stretch-updates main
deb [arch=amd64] https://download.docker.com/linux/debian stretch stable
# deb-src [arch=amd64] https://download.docker.com/linux/debian stretch stable
deb https://matrix.org/packages/debian/ stretch main
# deb-src https://matrix.org/packages/debian/ stretch main 

There was also one more repository that I removed because it was down, which if I am not mistaken was deb ftp.de.debian.org sid main. I cannot re-add this repository, however, because of this error message:

E: The method 'ftp' is unsupported and disabled by default. Consider switching to http(s). Set Dir::Bin::Methods::ftp to "ftp" to enable it again.
E: Failed to fetch ftp://ftp.de.debian.org/dists/sid/InRelease  
E: Some index files failed to download. They have been ignored, or old ones used instead.

Also, apt-get clean, apt-get install -f, apt-get update and apt-get upgrade all did nothing. Neither does apt-get dist-upgrade.

  • Hello and welcome to the Unix and Linux stack exchange site. Please review the help center for information on how best to post to this site. Please edit your post to include some additional context. What is the contents of your /etc/apt/sources.list? – kemotep Feb 7 at 11:50
  • I edited the file with the information. Thank you! – boogledoogle Feb 7 at 20:10
  • To clarify, Is your goal to complete the installation of virt-manager or all of the packages failing to install as outlined in your post? – kemotep Feb 7 at 20:29
  • I am thinking this is a case of FrankenDebian. Depending on the circumstances it might be easier to backup important data and start with a fresh install. – kemotep Feb 11 at 15:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.