0

I am trying to mount a NAS from a RHEL-7.4 VM. This is in a closed environment, so no internet whatsoever.

I can ping the sever without issue (IP and FQDN both work) and I can see the shares that are available using smbclient -L, so I'm assuming that I'm authenticating OK, but when I try to actually mount it I keep getting errors. I've been researching this for over a week and seen several solutions that only include a different command variation, but very few (if any) that actually explain the why behind the error and how to best fix the issue.

What I've Tried

SMBFS (all versions):

$ sudo mount -v -t cifs -o user=<usr //<server>/share  /mnt/share
---
$ sudo mount -v -t cifs -o user=<usr> //<server>/share /mnt/share
---
$ sudo mount -v -t cifs -o vers=<vNum>,user=<usr> //<server>/share /mnt/share
---
$ sudo mount -v -t cifs -o vers=<vNum>,user=<usr> //<server>/share /mnt/share
---
$ sudo mount -v -t cifs -o vers=<vNum>,user=<usr>,domain=<domain> //<server>/share /mnt/share
---
$ sudo mount -v -t cifs -o vers=<vNum>,user=<usr>,sec=krb5 //<server>/share /mnt/share
---
$ sudo mount -v -t cifs -o vers=<vNum>,credentials=$HOME/<credFile> //<server>/share /mnt/share

NFS:

$ sudo mount -v -t nfs <server>:/share /mnt/share
---
$ sudo mount -v -t nfs <server>:/share /mnt/share -o user=<user>

Errors:

mount error(2): No such file or directory mount error(112): Host is down

  • To start with, you'll have to know how the sharing is configured on the Windows side. Is nfs even available? Is it using NTLM and if so, which version? Are you sure that you are connecting as a user who has access to the share? – Nasir Riley Feb 6 at 23:03
  • I'm assuming nfs is available; it (seems to) successfully authenticate and try to attach the share. I'll give the NTLM a shot. I just need to do sec=NTLM, right? – RedKoder Feb 7 at 14:40
  • I tried every sec=<option> variation available, and each time I got mount error(2) No such file or directory. – RedKoder Feb 7 at 15:45
  • The option is sec=ntlm. Of course, it also depends on whether NTLM is being used on the file server and which version. If you are sure that nfs is available and it successfully mounts them why do you need to mount it with cifs? – Nasir Riley Feb 7 at 15:50
  • But it's not successfully mounting; I get mount error(2): No such file or directory with both cifs and nfs. My assumption is that I'm authenticating successfully, but something else after that isn't lining up and causing everything to break. However, i don't know enough about how mount works to say that definitively. – RedKoder Feb 7 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.