0

I have used Fedora wonderfully before on my MacBook Pro 11, 1 with working wifi set up as per this guide. It describes the process of adding the RPMFusion repos and installing the akmods broadcom-wl driver from there, and it worked fine when I installed Fedora 27. However, when I have tried to do this with Fedora 29, it simply does not work. Every step of the process, from adding the RPMFusion repo, to installing the broadcom-wl package, seems to work. However, when running sudo akmods, this error pops up:

Checking kmods exist for 4.18.16-300.fc29.x86_64           [  OK  ]
Building and installing wl-kmod                            [FAILED]
Building rpms failed; see /var/cache/akmods/wl/6.30.223.271-20-for-4.18.16-300.fc29.x86_64.failed.log for details

Hint: Some kmods were ignored or failed to build or install.
You can try to rebuild and install them by by calling
'/usr/sbin/akmods --force' as root.

The mentioned file says this in turn:

2019/02/06 10:56:15 akmods: Building RPM using the command '/sbin/akmodsbuild --kernels 4.18.16-300.fc29.x86_64 /usr/src/akmods/wl-kmod.latest'
mv: cannot stat '/tmp/akmodsbuild.YtdSnJrq/RPMS/x86_64/*': No such file or directory
2019/02/06 10:56:15 akmodsbuild: * Rebuilding /usr/src/akmods/wl-kmod.latest for kernel(s) 4.18.16-300.fc29.x86_64:
2019/02/06 10:56:15 akmodsbuild: Failed to move /tmp/akmodsbuild.YtdSnJrq/RPMS/x86_64/* to /tmp/akmods.0sJvuLYJ/results
2019/02/06 10:56:15 akmods: Building rpms failed; see /var/cache/akmods/wl/6.30.223.271-20-for-4.18.16-300.fc29.x86_64.failed.log for details

I'm really lost

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.