4

Machine: Acer Chromebook 14 CB3-431

Trying to write a udev rule to simply ignore the onboard Intel Wireless 7265 (Dual Band Wireless-AC 7265)

On boot, modemmanager hangs the boot process with this informative message:

Couldn't check support for device  '/sys/devices/pci0000:00/0000:00:1c.2/0000:02:00.0' not supported by any plugin

Info:

# udevadm info -a -p /sys/class/net/wlp2s0

  looking at device '/devices/pci0000:00/0000:00:1c.2/0000:02:00.0/net/wlp2s0':
    KERNEL=="wlp2s0"
    SUBSYSTEM=="net"
    DRIVER==""
    ATTR{carrier_changes}=="4"
    ATTR{carrier}=="1"
    ATTR{dev_id}=="0x0"
    ATTR{carrier_down_count}=="2"
    ATTR{proto_down}=="0"
    ATTR{address}=="7c:b0:c2:d5:88:dd"
    ATTR{operstate}=="up"
    ATTR{link_mode}=="1"
    ATTR{dormant}=="0"
    ATTR{mtu}=="1500"
    ATTR{gro_flush_timeout}=="0"
    ATTR{carrier_up_count}=="2"
    ATTR{ifalias}==""
    ATTR{netdev_group}=="0"
    ATTR{ifindex}=="2"
    ATTR{broadcast}=="ff:ff:ff:ff:ff:ff"
    ATTR{type}=="1"
    ATTR{dev_port}=="0"
    ATTR{name_assign_type}=="4"
    ATTR{addr_assign_type}=="3"
    ATTR{addr_len}=="6"
    ATTR{tx_queue_len}=="1000"
    ATTR{iflink}=="2"
    ATTR{flags}=="0x1003"

  looking at parent device '/devices/pci0000:00/0000:00:1c.2/0000:02:00.0':
    KERNELS=="0000:02:00.0"
    SUBSYSTEMS=="pci"
    DRIVERS=="iwlwifi"
    ATTRS{broken_parity_status}=="0"
    ATTRS{subsystem_device}=="0x5010"
    ATTRS{dma_mask_bits}=="36"
    ATTRS{vendor}=="0x8086"
    ATTRS{local_cpus}=="f"
    ATTRS{class}=="0x028000"
    ATTRS{numa_node}=="-1"
    ATTRS{max_link_width}=="1"
    ATTRS{msi_bus}=="1"
    ATTRS{device}=="0x095a"
    ATTRS{current_link_width}=="1"
    ATTRS{max_link_speed}=="2.5 GT/s"
    ATTRS{local_cpulist}=="0-3"
    ATTRS{driver_override}=="(null)"
    ATTRS{d3cold_allowed}=="1"
    ATTRS{irq}=="313"
    ATTRS{revision}=="0x59"
    ATTRS{current_link_speed}=="2.5 GT/s"
    ATTRS{consistent_dma_mask_bits}=="36"
    ATTRS{ari_enabled}=="0"
    ATTRS{devspec}==""
    ATTRS{enable}=="1"
    ATTRS{subsystem_vendor}=="0x8086"

  looking at parent device '/devices/pci0000:00/0000:00:1c.2':
    KERNELS=="0000:00:1c.2"
    SUBSYSTEMS=="pci"
    DRIVERS=="pcieport"
    ATTRS{secondary_bus_number}=="2"
    ATTRS{subordinate_bus_number}=="2"
    ATTRS{broken_parity_status}=="0"
    ATTRS{subsystem_device}=="0x7270"
    ATTRS{dma_mask_bits}=="32"
    ATTRS{vendor}=="0x8086"
    ATTRS{local_cpus}=="f"
    ATTRS{class}=="0x060400"
    ATTRS{numa_node}=="-1"
    ATTRS{max_link_width}=="1"
    ATTRS{msi_bus}=="1"
    ATTRS{device}=="0x22cc"
    ATTRS{current_link_width}=="1"
    ATTRS{max_link_speed}=="2.5 GT/s"
    ATTRS{local_cpulist}=="0-3"
    ATTRS{driver_override}=="(null)"
    ATTRS{d3cold_allowed}=="1"
    ATTRS{irq}=="311"
    ATTRS{revision}=="0x35"
    ATTRS{current_link_speed}=="2.5 GT/s"
    ATTRS{consistent_dma_mask_bits}=="32"
    ATTRS{ari_enabled}=="0"
    ATTRS{devspec}==""
    ATTRS{enable}=="1"
    ATTRS{subsystem_vendor}=="0x8086"

  looking at parent device '/devices/pci0000:00':
    KERNELS=="pci0000:00"
    SUBSYSTEMS==""
    DRIVERS==""

I've tried writing a (few different) rules for udev rather unsuccessfully:

KERNELS=="0000:02:00.0", ENV{ID_MM_DEVICE_IGNORE}="1"

The rule is read but apparently incorrect as the boot still hangs

    udevadm test /sys/class/net/wlp2s0 /snip/ created db file
     '/run/udev/data/n2' for
     '/devices/pci0000:00/0000:00:1c.2/0000:02:00.0/net/wlp2s0' ACTION=add
     DEVPATH=/devices/pci0000:00/0000:00:1c.2/0000:02:00.0/net/wlp2s0
     DEVTYPE=wlan ID_BUS=pci ID_MM_CANDIDATE=1 ID_MM_DEVICE_IGNORE=1
     ID_MODEL_FROM_DATABASE=Wireless 7265 (Dual Band Wireless-AC 7265)
     ID_MODEL_ID=0x095a ID_NET_NAME_PATH=wlp2s0
     ID_PCI_CLASS_FROM_DATABASE=Network controller
     ID_PCI_SUBCLASS_FROM_DATABASE=Network controller
     ID_VENDOR_FROM_DATABASE=Intel Corporation ID_VENDOR_ID=0x8086
     IFINDEX=2 INTERFACE=wlp2s0 SUBSYSTEM=net USEC_INITIALIZED=59063
1

This has been solved by Aleksander himself. :) A summary from the mailing list:

Aleksander:

That is just an informative message. MM is not touching that interface for anything, it's just saying it cannot be used as part of a modem, as there is no control port. No udev rule to ignore the device will be hit, because MM is not even trying to use the device. That is definitely nothing to worry about.

Is MM really hanging the boot process? What exactly are you seeing? Any actual logs you can share?

At one time, it did appear to be MM hanging the boot process because once MM was removed, the boot hang was also removed. Now, it seems MM is not the culprit!*
Now, I only wonder, is it necessary that MM provide the informative message at all?

I think that message is not debug, and I agree that it may be a bit confusing to see it :D I'll see what I can do to silence those.

-- Aleksander

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.