94

I accidentally screw up my tmux terminal after cating a binary file. Now my tmux is messed up. Detaching and re-attaching doesn't help, nor does a redraw (C-b r). Running reset only redraws the active pane, not the rest. Running ssty sane either in- or outside tmux doesn't help either.

tmux messed up

Within each pane, I have normal feedback from what I type (the initial call of reset immediately after the terminal got messed up solved this), but I can't seem to fix the status-bar.

In gnome-terminal, every update to the status-bar leads to the status-bar to grow (see screenshot above). For example, this happens when I run a new application, when I switch panes, or when I resize a pane. Forcing a redraw (By C-b r, by running reset or via the gnome-terminal menu) shrinks back the status-bar to a single line, but it remains corrupted.

In xterm, the status-bar does remain within one line, but it remains corrupted as pictured.

I'm using tmux 1.5.

  • How do I fix my tmux-terminal?

This bug report from 2008 seems to describe the same issue, but it was marked as fixed. I don't know in what version it was fixed, but tmux 1.5 ought to include a fix from 2008.

  • Just had this problem, and "clear" worked for me. – user149818 Dec 2 '14 at 16:05
  • 1
    In case somebody runs into the same problem, after doing all of the above, my tmux status bar was still messed up. Setting the window option status-right repaired it. – user96241 Dec 28 '14 at 14:15
  • 2
    The above suggestion fixed it for me too. The command to do that was: Control + b + : and then set -g status-right "#H" to set status-right to the hostname. – Mayank Jul 21 '16 at 0:45
83

Try renaming window 4

  • Switch to window 4: Control+b 4
  • Rename window: Control+b , Control+u myNewname

(Thats a comma in the middle)

Or: Control+b :rename-window myNewname

  • 1
    Renaming the window works like a charm – exhuma Mar 31 '15 at 8:30
  • 4
    You need to clear the name before typing the new one. The easiest way is with ctrl+u, so the full sequence is ctrl+b , ctrl+u newname – z0r May 22 '15 at 4:46
  • 1
    Sweet - this works for byobu as well (f8, <newname>) – ali_m Nov 18 '15 at 16:55
  • Why is the Control-u needed? Control-, is already renaming right? Though I can confirm that it was needed in my case, is it a reset character of some kind? – hbogert Jan 30 '17 at 10:20
  • 1
    Control-u clears the line. if you every fatfinger your password in a terminal and know it, you can clear the entry using control-u, instead of hitting backspace 20 times – Rqomey Jan 31 '17 at 22:00
54

You need two command sequences to cleanup the mess:

First, run this in the garbled window (this works even when you are in ssh):

stty sane; printf '\033k%s\033\\\033]2;%s\007' "`basename "$SHELL"`" "`uname -n`"; tput reset; tmux refresh

Then run this on the computer which runs tmux (it works inside and outside of tmux):

The following command affects all tmux instances, which may change the left status of more than the current window. If you do not need that feature, leave it away.

tmux list-windows -a | while IFS=: read -r a b c; do tmux set-window-option -t "$a:$b" automatic-rename on; done

Explained in detail

This was assembled to address all the bits found in other answers and comments. There currently seems only a minor bit left with the second command. (See in the "missing bit" below).

To understand how this works, let us first kill the status line of tmux and the tty. Afterwards we correct it again, using a method which should be always available (unlike command reset).

How to make a tmux terminal (assumes UTF-8) unusable

stty -echo; printf '\016\033k%2000s\\\033\033]2;\355\007' $'\302\217'

Warning: After running above command, the shell looks blind and deaf and seems only to talk bullshit in some unknown alien language. See below on how to repair this.

Explained:

  • stty -echo kills the terminal type response

  • printf '\016' does a SO, so you are on the alternate character set

  • printf '\033]2;%s\007' 'right status text' sets the right status, in this case $'\355', which exposes a presentation bug

  • printf '\033k%2000s\033\\' $'\302\217' sets the window title name

This might be the combination you can see on the terminal after some interactive command crashed and dropped back into the shell. (With /bin/cat you cannot provoke stty -echo IMHO, but interactive commands like vim usually set this.)

Now clean up this mess

stty sane; printf '\033k%s\033\\\033]2;%s\007' "$(basename "$SHELL")" "$(uname -n)"; tput reset; tmux refresh

Note: If you use copy and paste (you probably need to hold down Shift while pasting), you probably cannot see your paste if you have used the above command to mess up with your tty. Hence, just blindly press the Enter key after pasting this.

Explained:

  • stty sane sets "sane" terminal parameters, so you get back your echo while typing

  • printf '\033k%s\033\\' "$(basename "$SHELL")" sets the window title back to normal. You can use tmux rename-window "$(basename "$SHELL")" alternatively, however tmux rename-window is limited to tmux where the escape sequence always works.

  • printf '\033]2;%s\007' "$(uname -n)" resets the status-right to be shown as default. (Note that you should not use tmux set status-right "something", because it just outputs the pane title which got corrupt, so status-right just exposes some presentation bug. Also note, that I did not find a tmux command to set the pane title directly.)

  • tput reset resets the terminal, just in case this has been messed with

  • tmux refresh refreshes the screen to get rid of other debris which might have shown up

Missing bit

The printf '\033k%s\033\\' "$(basename "$SHELL")" looses the standard ability of tmux to present the current command in the left status area. After printf '\033k%s\033\\' "something" was executed this ability is lost and I did not find a good way, yet, how to bring it back as it was before.

But, as noted in the comments below, you can activate a similar feature of tmux as a replacement with following tmux setting:

set-window-option automatic-rename on
  • Either do this in the tmux command line, which can be reached in the current window with "Escape" : (where "Escape" is your tmux command key) and then enter the command.

  • Or excute tmux set-window-option automatic-rename on in your current terminal, but this fails in case you are not directly on the right shell level, for example it does not work within sudo or ssh.

  • Or open another window in the current tmux session and execute following command:

    for a in `tmux list-windows | sed 's/:.*//'; do tmux set-window-option -t "$a" automatic-rename on; done`
    
  • Or open another shell to the computer which is running tmux and execute following command (this is outside of tmux):

    tmux list-windows -a | while IFS=: read -r a b c; do tmux set-window-option -t "$a:$b" automatic-rename on; done
    

PS: Thanks to all who helped to assemble this solution.

  • 2
    Please note the uname -n instead of hostname -s. hostname is dangerous in root context, as you might end up with your host renamed to -s on elder Linux/Unix where hostname does not grok options. – Tino Jan 5 '16 at 13:00
  • Not resetting the pane title makes me sad too; that's why I'm even here in the first place. Thank you for being the only one on the page who at least acknowledges that shortcoming! – EvanED Jan 19 '16 at 22:54
  • 2
    Consider also "tmux setw automatic-rename" after fixing the window title – EB. May 3 '16 at 20:03
  • The stty sane part helped me when my terminal was screwed up and didn't show anything. Thank you! – johnny Aug 30 '16 at 6:10
  • If you want the "missing bit", i. e. the currently running command displayed in the left status area, you can use the tmux command set-window-option automatic-rename. – David Foerster Jul 23 '17 at 11:34
26

The specific problem you are seeing has to do with the name/title of window 4. A combination of being too long (obviously) and containing strange characters which cause tmux to measure it as being shorter (so it fails to properly limit the status bar to the width of the screen) I am not sure how to reset it (on mine it tracks the name of the foreground process), you may have to close the window.

  • 4
    default to rename a window is ^b - , – Rob Dec 6 '12 at 4:17
  • 8
    In case the keyboard shortcut in @Rob's comment confuses you, it's Ctrl-b then ,. – Doug Paul Feb 17 '14 at 18:09
  • Note that when when you rename a window, the field is pre-populated with the current window name (and your cursor is at the end of that name). Since my window name was a long sequence of garbage, I had to hold down Backspace for a minute to clear the current name. For me, visual feedback eventually made it clear that the entire old name had been erased. – Doug Paul Feb 17 '14 at 18:10
  • you can also use Ctrl-b :rename-window <name goes here>; this uses the tmux command system instead of the keyboard shortcut for that command. – Abbafei Jul 31 '15 at 2:08
5

simply do this $ reset && tmux rename-window <new_window_name>

5
tmux set-option -g status off && tmux set-option -g status on 

fixed this for me when something other than the window name was corrupted and I couldn't be bothered to figure out what it was.

2

tmux might only constitute part of the problem. You may have to invoke stty sane at the command line. This resets the in-kernel TTY drivers to some set of default values that usually let you proceed. If the TTY drivers are messed up enough, you may have to type stty sane "blind", that is, without on-screen feedback.

  • stty sane doesn't solve the problem either. I do have on-screen feedback, within each of tmux panes I can type and have feedback as normal, but as soon as tmux needs to draw something (e.g. running a new application, switching or resizing panes) the status-bar moves into the panes... – gerrit Oct 4 '12 at 12:39
2

Try to reload your config file?

Ctrlb, then: :source-file ~/.tmux.conf

  • best solution so far. – dave Sep 29 '15 at 10:41
-3

to fix the issue for me:

I just killed the issue pane and window, and created a new window and pane.

In the issue pane, CTRL+AX and CTRL+AC.

  • this way for me again. no other ways can help – itech May 22 '17 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.