0

I have a 2 cpu server running SLES 11.4 x86-64 and it has 1.5 tb of RAM.

>free -g

             total       used       free     shared    buffers     cached
Mem:          1514        284       1230        268          0        269

Running a number crunching software, which has worked fine in the past, giving us problems lately running slow and crashing, trying to figure out why.

I tried to do a echo 3 > /proc/sys/vm/drop_caches and that did not work. It usually puts cached to zero, did not work this time.

my questions are:

  • what would cause echo 3 > /proc/sys/vm/drop_caches not to work?
  • does the cached value even matter?
  • is there another way to accurately find out current state of RAM used/cached/whatever besides the free command?
  • given this type of problem and troubleshooting, any recommendation?
0

for the crashing part check dmesg, for the slowness try vmstat 2 and keep it running when you execute the crunshing app, it should shed some light on what the bottleneck might be.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.