1

I found this guide to installing a legacy Nvidia driver to Linux:

https://wiki.debian.org/NvidiaGraphicsDrivers#Version_304.135_.28legacy_GPUs.29-1

And I am having trouble with this particular command.

# aptitude -r install linux-headers-$(uname -r|sed 's/[^-]*-[^-]*-//') nvidia-legacy-304xx-driver

that command is allegedly to grab the particular driver I need.

I suppose "uname" is my user name, but the sed command seems to be missing some values. I'm using the latest Deepin, and when I try to install the drivers with the standard command, it always grabs the latest driver, which this card cannot use.

  • 1
    What does your uname -r produce? Then, what does uname -r|sed 's/[^-]*-[^-]*-//' produce? (Call the output of that command, WHATEVER.) Now, do you have linux-headers-WHATEVER in the package repository, where WHATEVER matches that output? If not, you're going to need to hunt for a suitable alternative. – roaima Feb 4 at 21:37
  • 1
    If you had to reset your StackExchange account, why not ask the moderators for assistance. The ones we have here are pretty helpful, and I see no reason why they wouldn't be on Stack Exchange too. – roaima Feb 4 at 21:42
  • 2
    Finally, for now anyway, uname is nothing to do with your username. It's a command that returns various bits of headline information about your system's currently running kernel. You can read its documentation with man uname. – roaima Feb 4 at 21:45
  • 2
    Bottom line: type what it says: uname⁠ ⁠-r|sed⁠ ⁠'s/[^-]*-[^-]*-//'.  There are no placeholders in that command. – G-Man Feb 4 at 21:46
  • Thanks I ran it that way, apparently it is throwing some error. I’ll come back here and edit this once I run it again and put that error up. – Jonny Vee Feb 5 at 1:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.